Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Mounts + Accessories
Reply
Anonymous
Posts: 0

remo won't power on (the described way / 3sec power press)

[ New ]

my remo wont power on with the 3sec power button press.

I have to press 8sec's (as if pairing) and then shortly press the shutter button.

 

strange ? or is the manual wrong ?

what am I doing worng ?


Accepted Solutions
GoPro
Posts: 3,924

Re: remo won't power on (the described way / 3sec power press)

[ New ]

Hi @Anonymous,

 

Sorry to hear you are having some trouble getting that to turn on. I just tested that out and what I would recommend is firmly press the button for 1-3 seconds and then let go. At that point the REMO should turn on. It might take a few times to get used to but that should do the trick. If you continue to hold the button down for longer than 3 seconds it will only turn on once it goes into pairing mode. Hope that helps!

 

Best,

Ryan

View solution in original post


All Replies
GoPro
Posts: 3,924

Re: remo won't power on (the described way / 3sec power press)

[ New ]

Hi @Anonymous,

 

Sorry to hear you are having some trouble getting that to turn on. I just tested that out and what I would recommend is firmly press the button for 1-3 seconds and then let go. At that point the REMO should turn on. It might take a few times to get used to but that should do the trick. If you continue to hold the button down for longer than 3 seconds it will only turn on once it goes into pairing mode. Hope that helps!

 

Best,

Ryan

Anonymous
Posts: 0

Re: remo won't power on (the described way / 3sec power press)

[ New ]
thank you !!
The issue is, that one has to release the power on button "within" 3 seconds.
I took the manual for granted and "held" for 3 secs - which just results in no power on.

good to know that this is an active forum ...
Anonymous
Posts: 0

Re: remo won't power on (the described way / 3sec power press)

[ New ]

I bought 'remo' today and turned it on for the first time, but there is no change in the power indicator. Red light, green light I can not confirm anythin. When I press the power button for a short time or long time, there is no change.

Anonymous
Posts: 0

Re: remo won't power on (the described way / 3sec power press)

[ New ]

Hi,

did you find any way to solve your problem?

I received mine yesterday. No green or red light blinking, no detection on my Imac. I don't even know if it is charging or not !!

GoPro Community Manager
Posts: 7,797

Re: remo won't power on (the described way / 3sec power press)

[ New ]

If you're still having issues, please reach out to our Support team at https://gopro.com/help/ContactUs and we'll do our best to help you out.

Anonymous
Posts: 0

Re: remo won't power on (the described way / 3sec power press)

[ New ]

exactly the same for me! There is a solution ? where it does not work, mine is new. : smileysad:

Anonymous
Posts: 0

Re: remo won't power on (the described way / 3sec power press)

[ New ]

I'm having the same problem and this is the second one I've got. I just went back to Argos to change it as it seems not to charge/ turn on or do anything. Please help GoPro. Is there a bad batch out there? I've tryed charing through my laptop, desktop pc, and a usb charger nothing.