Ask a Question
GoPro Support Hub Find a solution. Share a solution. Ask a question. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Mounts + Accessories
Posts: 1

Wi-Fi Remote control dose'nt work without connecting to charge

Hi My remote can be turned on when the powercable is connected to a powersource (adapter or laptop). When it is turned off and connecte to a power source it shows a full battery icon.

As soon as I disconnect the powercable it turns dead. I've tried resetting it (the 20second trick) and I've tried four different adapters but nothing solves the problem. 

What to do?


Posts: 7,699

Re: Wi-Fi Remote control dose'nt work without connecting to charge

Hi @timk8574


Based on the information shared, this seems to be a battery issue.

Kindly check if the contact points on the remote are dirty from use it can disrupt the connection and inhibit the remote's ability to charge. Be sure that those contact points are free of dirt and debris by using a cotton swab with rubbing alcohol or a toothpick to clean the metal contacts on the bottom of the remote. 

The remote should reach a full charge within 4 hours if you use the computer, and about 2 hours if you use the wall charger.  When the remote is done charging the red light will turn off, and in some cases it will turn on and show a radiating Wi-Fi symbol. If you see this symbol be sure to disconnect it from the charger and power it off.