Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Mounts + Accessories
Reply
Tourist
Posts: 2

Smart remote has stopped connecting to my Hero 7.

[ New ]
Since I updated my Hero 7 black last week I cannot get my smart remote to stay connected. Sometimes it connects right away and then drops connection after about 10 minutes and then won’t reconnect. I have reset both the remote and the Hero 7 and then set a new connection but no joy it is exactly the same. Any ideas
T

Accepted Solutions
GoPro
Posts: 29,803

Re: Smart remote has stopped connecting to my Hero 7.

[ New ]

Hi @trevorm0065

 

Just to be sure that everything has been covered, please go over the steps below:

 

  1. Turn off the Smart Remote and HERO7 Black.
  2. Reset the Smart Remote by pressing and holding the Power/Mode button on the remote for about 8 to 10 seconds. Leave the remote powered OFF for the meantime.
  3. Reset the Wi-Fi connections on your camera. Go to Preferences > Connections, and then tap Reset Connections.
  4. Pair the two devices:
    • Power off your remote. Power ON the HERO7 Black camera. On the back of LCD screen, swipe down from the top of screen and tap Preferences. Tap Connections  Tap Connect Device and scroll down to Smart Remote. Tap Smart Remote to enable pairing mode. Now set your camera aside and pick up the remote.
    • With the remote powered OFF, press and hold the red Shutter button on the remote. While continuing to hold the red button, press the white Power button once briefly. The remote will power on and show two arrows moving towards each other. You can let go of the red button at this time. Now the remote is in pairing mode.
    • At this point, the camera and remote should both show arrows moving towards each other. After one minute or less, the camera and remote should pair. **NOTE: The remote may ask you to pair another, press the Mode button to highlight "No", then press the red button to select it. Alternatively, you may see the pairing screen (arrows) and the number of connected cameras appear (typically "1"). Press the red shutter button on the Remote to complete the paring process.

    • The remote should now mirror the camera's front LCD screen, indicating that pairing was successful.

Should it still be the same, the best path forward is to contact our Support Team.

They are available by phone or chat through https://gopro.com/help/ContactUs

 

Thanks!
Ej

 

View solution in original post


All Replies
GoPro
Posts: 29,803

Re: Smart remote has stopped connecting to my Hero 7.

[ New ]

Hi @trevorm0065

 

Just to be sure that everything has been covered, please go over the steps below:

 

  1. Turn off the Smart Remote and HERO7 Black.
  2. Reset the Smart Remote by pressing and holding the Power/Mode button on the remote for about 8 to 10 seconds. Leave the remote powered OFF for the meantime.
  3. Reset the Wi-Fi connections on your camera. Go to Preferences > Connections, and then tap Reset Connections.
  4. Pair the two devices:
    • Power off your remote. Power ON the HERO7 Black camera. On the back of LCD screen, swipe down from the top of screen and tap Preferences. Tap Connections  Tap Connect Device and scroll down to Smart Remote. Tap Smart Remote to enable pairing mode. Now set your camera aside and pick up the remote.
    • With the remote powered OFF, press and hold the red Shutter button on the remote. While continuing to hold the red button, press the white Power button once briefly. The remote will power on and show two arrows moving towards each other. You can let go of the red button at this time. Now the remote is in pairing mode.
    • At this point, the camera and remote should both show arrows moving towards each other. After one minute or less, the camera and remote should pair. **NOTE: The remote may ask you to pair another, press the Mode button to highlight "No", then press the red button to select it. Alternatively, you may see the pairing screen (arrows) and the number of connected cameras appear (typically "1"). Press the red shutter button on the Remote to complete the paring process.

    • The remote should now mirror the camera's front LCD screen, indicating that pairing was successful.

Should it still be the same, the best path forward is to contact our Support Team.

They are available by phone or chat through https://gopro.com/help/ContactUs

 

Thanks!
Ej

 

Tourist
Posts: 2

Re: Smart remote has stopped connecting to my Hero 7.

[ New ]

Hi EJ

 

Thank you for the comprehensive instructions. I have not tried them yet as everything seems to have righted itself at the moment after a couple of days with no connection on Sunday I turned on the remote to check the battery status and a couple of seconds later my Hero 7 turned itself on without touching it and it was perfectly paired and worked fine. Since then I have used it four orfive times and it has worked fine. I don’t touch the power button on the cam at all now I just use the power button on the smart remote and it turns both on and off as required. Maybe it was user error previously in that I was turning both items on with their respective power buttons and that clearly isn’t required.

 

i have saved your instructions in case off further problems.

 

many thanks for your reply.

 

Trevor

GoPro
Posts: 29,803

Re: Smart remote has stopped connecting to my Hero 7.

[ New ]

Sure! @trevorm0065

Glad to hear that it is working.

Feel free to post back if something comes up.

 

 

Stay stoked!

Ej