Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Mounts + Accessories
Reply
Highlighted
Sightseer
Posts: 1
Accepted Solution

Poor adhesive

I bought a GraBag on my trip to Deer Velley to mount my camera to my helmet and get great ski movies. Unfortunately the adhesive did not hold well and my camera fell off my helmet. I had followed all the proper installation guidelines cleaning surfaces, etc. 

pluckily my friend I was skiing with retrieved my camera. I have my receipt from Jan’s Snow Park at Deer Valley. I would hope you could help with a good replacement for this first poor mount media. If you wish I could scan in my receipt and send it 


Accepted Solutions
Highlighted
Explorer
Posts: 12,956

Re: Poor adhesive

This is a member to member forum. I think you want to contact the GoPro Support Team with this. You can chat or call them using this link https://gopro.com/help/ContactUs

Just FYI: the adhesive is made by 3M 4991 VHB.
You should always wait at least 24 hours after application before using a newly applied mount. The surface area must be clean and completely smooth.

View solution in original post


All Replies
Highlighted
Explorer
Posts: 12,956

Re: Poor adhesive

This is a member to member forum. I think you want to contact the GoPro Support Team with this. You can chat or call them using this link https://gopro.com/help/ContactUs

Just FYI: the adhesive is made by 3M 4991 VHB.
You should always wait at least 24 hours after application before using a newly applied mount. The surface area must be clean and completely smooth.