Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Mounts + Accessories
Reply
Highlighted
Tourist
Posts: 4
Accepted Solution

MEDIA MOD (HERO9 BLACK)

I bought the MEDIA MOD (HERO9 BLACK) at the same time as the Gopro Hero9 main unit that arrived today, but the main unit does not recognize the MEDIA MOD (HERO9 BLACK).

What should i do?

 


Accepted Solutions
Highlighted
GoPro
Posts: 16,023

Re: MEDIA MOD (HERO9 BLACK)

Hello, @chuttanteto. There seems to be an issue with the actual port on the camera. Considering this, the next step would be to engage our Support team for further assistance. 

 

To connect with them, visit https://gopro.com/help/ContactUs . Once there, select "Contact Us" and proceed with either chat or a callback request. 


Should you encounter any issue scheduling a callback or a live chat, please ensure that you are not blocking cookies and have your pop-up blocker disabled. 

View solution in original post


All Replies
Highlighted
Tourist
Posts: 4

Re: MEDIA MOD (HERO9 BLACK)

[ Edited ]

By the way, the main unit can be charged and recognizes the PC.

You can only charge it via MEDIA MOD (HERO9 BLACK).

Highlighted
GoPro
Posts: 9,771

Re: MEDIA MOD (HERO9 BLACK)

@chuttanteto, please make sure to have the latest firmware installed on your GoPro. Also, reinstalling the firmware update of the camera can also help correct any errors with the current software installation.Using an SD card adapter, connect your microSD card to your computer and follow the Manual Update instructions specified in this article: https://community.gopro.com/t5/en/How-to-Update-GoPro-Cameras/ta-p/394229 

 
Additionally, performing a factory reset in the camera may help. 
 
Let us know how it goes. 

Highlighted
Tourist
Posts: 4

Re: MEDIA MOD (HERO9 BLACK)

Thank you for your reply.

I immediately tried it as instructed, but the situation did not change.
Is there any other way?

Highlighted
Tourist
Posts: 4

Re: MEDIA MOD (HERO9 BLACK)

After that, I will report the results of various verifications on my own.
First I reinstalled the firmware and tried to reset all the settings.
Still, the result remains the same.
Eventually, I was able to confirm that charging was not possible even with the USB of the main unit.
You can charge it by moving the USB cable a little, but you can't charge it again with a little adjustment.
It is in a state where it may or may not be recognized even on a PC.

It can be inferred that the cause of this time is probably due to poor contact of the UBS terminal of the main unit.
You can check if there are two points each for the main unit and MEDIA MOD (HERO9 BLACK), but unfortunately there is only one point for each, so it is not possible to determine which was the cause.

There is no better way to deal with it.

These products just arrived yesterday, so please replace the HERO9 BLACK body with the MEDIA MOD (HERO9 BLACK).

What kind of procedure should I take?

Highlighted
GoPro
Posts: 16,023

Re: MEDIA MOD (HERO9 BLACK)

Hello, @chuttanteto. There seems to be an issue with the actual port on the camera. Considering this, the next step would be to engage our Support team for further assistance. 

 

To connect with them, visit https://gopro.com/help/ContactUs . Once there, select "Contact Us" and proceed with either chat or a callback request. 


Should you encounter any issue scheduling a callback or a live chat, please ensure that you are not blocking cookies and have your pop-up blocker disabled.