Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Mounts + Accessories
Reply
Tourist
Posts: 5

Hero9 - Media Mod not recognized

[ New ]

Even after following instructions given to others who had a similar problem:

- media mod cannot be selected in the preferences

- only in-camera audio is used by the camera

- charging fine by either the camera or the mod

IMG_20210220_094141.jpg
GoPro
Posts: 23,316

Re: Hero9 - Media Mod not recognized

[ New ]

Hi @adroitflas2526

 

if you haven't yet, please try re-flashing the software.

Follow the manual update steps on https://gopro.com/en/us/update/hero9-black

Once done, reset the camera. Go to Preferences> Reset> Factory Reset

 

Let us know how it goes.
You may also reach out to our Support Team through https://gopro.com/help/ContactUs for further assistance.
 

Thanks!

Ej

Tourist
Posts: 5

Re: Hero9 - Media Mod not recognized

[ New ]

Hi there,

 

I had done that, to no avail. Just redid it, still does not detect the media mod.

 

JBL

GoPro
Posts: 11,878

Re: Hero9 - Media Mod not recognized

[ New ]

@adroitflas2526, if the issue persists after going through the suggested troubleshooting steps, our Support team will be able to assist you further in resolving this. You may reach out to them through https://gopro.com/help/ContactUs to initiate a callback request or chat with one of the representatives.

Tourist
Posts: 5

Re: Hero9 - Media Mod not recognized

[ New ]
I just did that. Haven't received the RMA yet, only a shipping label. Then apparently it will take the time for my return shipping, plus 10-14 business days (i.e. 2 to 3 weeks) for me to receive a replacement mod... So altogether 3 to 4 weeks before I can use one (if it works! - the initial media mod was brand new and never worked). Not impressed by the shipping choices of customer service.
GoPro
Posts: 23,316

Re: Hero9 - Media Mod not recognized

[ New ]

Hi @adroitflas2526

 

If you haven't received it yet, please reach out to Support to follow up on the RMA document.

https://gopro.com/help/ContactUs

 

Thanks!

Ej

Tourist
Posts: 5

Re: Hero9 - Media Mod not recognized

[ New ]

I just did that after 24hr of waiting for it in vain.

 

...and learned that contrary to instructions in the email with the shipping label, as well as the instructions from the CSA I previously talked with, I must send it only with the shpping label, and will receive no other document before sending it. 

 

This past Christmas was my first time buying a GoPro, and I figured it would be best to buy straight from GoPro. I have yet to see if the problem is fixed if/when I receive a replacement for that brand new Media Mod...in three weeks!

 

Definitely not impressed by:
- the lack of quality control

- the customer service, be it condradiction in instructions, poor clarity and redundant questions on the phone, or the choice of a super-slow shipping service

- the milking of customers with pricing of accessories... six adhesive mounts for $30! it feels like GoPro accessories are to the camera what inkjet cartridges are to printers: cash cows with pricing completely disconnected from their cost

GoPro
Posts: 23,316

Re: Hero9 - Media Mod not recognized

[ New ]

Thank you for the feedback @adroitflas2526

We have shared this with the team.

We'll have the email instructions checked.