Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Mounts + Accessories
Reply
Highlighted
Tourist
Posts: 2

Display Mod Not Working (09/15/20)

[ Edited ]

Excited to see that the Display Mod was shipped quickly and arrived today. Updated my GoPro firmware, and voila... the Display Mod just shows the battery level and the fact it has the icon to plug it into the Camera Mod (which it was). I don't have another Camera Mod, but I have a second Hero8 Black that I used to check, and it too isn't connecting. The instructions are "super light" on how to get it to work. I also have the Light Mod for the Camera Mod, but since that's a cold shoe mount, I don't think they interact.

Soooooooo... DOA Mod, or is there firmware issues at fault here or something else. I'm curious if anybody else who's gotten theirs currently are experiencing this same issue. 

IMG_6306.jpg
Highlighted
Tourist
Posts: 1

Betreff: Display Mod Not Working (09/15/20)

Display Mod funktioniert nicht

Highlighted
Tourist
Posts: 1

Betreff: Display Mod Not Working (09/15/20)

Habe heute mein Display mode erhalten. Es lässt sich nicht einschalten überhaupt geht nichts. Ich habe die neueste Software auf meine Hero 8. Was nun?. Das Teil hat über 2 Stunden am Ladegerät aufgeladen. beim anschließen der Kamera Mod geht die Hero 8 sofort aus und das Display kann man nicht bedienen bleibt schwarz.

Highlighted
Hiker
Posts: 90

Betreff: Display Mod Not Working (09/15/20)

Just got my display mod and it is working as it should. 

Highlighted
Sightseer
Posts: 1

Re: Display Mod Not Working (09/15/20)

I am experiencing the same issue. Not working.
My screen shows the same in the photo in this thread.
Highlighted
Tourist
Posts: 2

Re: Display Mod Not Working (09/15/20)

So assuming no software fix, and that there are a few in this thread experiencing the same... is this the display issue or the Media Mod case? Since the Hero8 does not have an independent HDMI connector, and that I tried this on two exact same Hero8s (bought within minutes of each other on the site) - I will assume the Display Mod and Media Mod are at issue. I would appreciate a CS/Support reply to this thread.

Also, REALLY bad timing to not only release a Display MOD within moments of the Hero9 release, since all discussions are now drowned out by the issues with Hero9s
Highlighted
Hiker
Posts: 28

Re: Display Mod Not Working (09/15/20)

I am having the same problem. I've had my GoPro Hero 8 for less than a year now and I've recently purchased the media and display mod.

 

When I first connected the display mod I had to update my GoPro Hero 8 through the GoPro app. This worked and I was able to use the Display mod.  

 

I turned off my GoPro and left the media mod and display mod (flipped down) attached. A few days later I turned on the GoPro to find the display mod showing the connection symbol.

 

I continued to disgnose the problem, it seems that my GoPro is not picking up the media mod. I found this out by going through the GoPro menu and didn't find the media mod sound options. 

 

I decided to test the USB-C ports. My GoPro charges normally, but when I attach the media mod and use the USB-C port, charging does not work. I assume something has happend to the media mod and not the GoPro or display mod.

 

I called customer service to get help on the issue, the support agent told me the standard questions, which I have completed most of them. She told me to update the GoPro manually and that was not successful. 

 

I believe my media mod is defective. I need to return it. 

 

Does anyone have any other options for this fix?