Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Webcam
Reply
Tourist
Posts: 4

preview not working in the webcam even though the blue dot is on

[ New ]

I have installed GoPro webcam utility and GoPro Desktop utility. Blue dot appears on the desktop utility but when i select show preview it is showing gopro's default image/screen(attached Screenshot for reference). I checked the sytem preferences and GoPro has access to the camera. I followed the steps as mentioned on the portal. Is there something else i need to do?

previewscreen.png
GoPro
Posts: 25

Re: preview not working in the webcam even though the blue dot is on

[ New ]
Can you post specs on your machine, OS version and what machine / cpu / graphics card you have. Also I would suggest a reboot.
Tourist
Posts: 4

Re: preview not working in the webcam even though the blue dot is on

[ New ]

Machine Specs:

 

Macbook Pro 13inch 2017

MacOS Catalina Version 10.15.5

2.5 GHz Dual-Core Intel Core i7

16GB 2133Mhz LPDDR3

Intel Iris Plus Graphics 640 1536MB

 

I rebooted the Macbook pro few times as well as restarted camera few times. Network setting shows that camera is connected. GoPro has access to camera in system settings. 

 

Tourist
Posts: 3

Re: preview not working in the webcam even though the blue dot is on

[ New ]

I have the same issue with the exact same screen. Preview is stuck on the picture of the gopro logo.

Mac info:

OSX Mojave 10.14.6

2009 MacPro flashed to a 5,1 with 3.46ghz 12 core CPU

GPU is a Sapphire Pulse Radeon RX580 8gb with 40gb RAM

 

I also rebooted the macpro multiple times and my camera. I also deleted and reinstalled the update on the computer and did the update again on my gopro. Still does not work for this computer.

 

Oddly my 2010 macbook pro 13in with 16gb memory dual core with base graphics picked up my gopro and showed the footage coming from my gopro in preview easily. So I know that the gopro update is correctly installed on my macbook pro, macpro and my gopro but for my macpro 5,1 something is not allowing it to show the footage in preview even with the blue light on.

 

GoPro
Posts: 25

Re: preview not working in the webcam even though the blue dot is on

[ New ]

My guess is there is some software that is preventing it.  Does your machine have a firewall enabled or any system protection software from a company?   I would be very curious to see if this is the issue.  

Tourist
Posts: 4

Re: preview not working in the webcam even though the blue dot is on

[ New ]

I turned off the firewall and even check that USB connections are working in Network. I also did SMC reset to make sure that there is no port being blocked or not working. I am not sure what else to look for. Everything looks good but there may be something that i am not aware of. GoPro option doesn't even appear for zoom app. I am running out of ideas but it would have been really nice if it worked. I will keep looking further if there is something else that i need to look for but if you come across some other idea please do let me know. 

Tourist
Posts: 2

Re: preview not working in the webcam even though the blue dot is on

[ New ]

I have the same problem, OS Catalina.  Preview not working

Sightseer
Posts: 3

Re: preview not working in the webcam even though the blue dot is on

[ New ]
I have the same issue with the following configuration. Also note, for me preview did work initially and then stopped working

Model Name: MacBook Pro
Model Identifier: MacBookPro16,1
Processor Name: 8-Core Intel Core i9
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache: 16 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB