Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Webcam
Reply
Tourist
Posts: 2

MIcrosoft Teams not showing GoPro as a device

[ New ]

Hi -

 

Did anyone have to do anything to have the GoPro show up as an available device? I can see the Preview, I can see the Device available for Google Meet and Twitch Studio but I don't see the GoPro Webcam as an option within Teams.

 

Any idea?

About Teams ->

You have Microsoft Teams Version 1.3.00.18164. It was last updated on 7/23/20

Sightseer
Posts: 1

Re: MIcrosoft Teams not showing GoPro as a device

[ New ]

I have the same problem, but it worked before the last update of Microsoft Teams (1.3.00.18164)

Tourist
Posts: 2

Re: MIcrosoft Teams not showing GoPro as a device

[ New ]

Looks like the Web Client works fine... Still worth GoPro reaching to Microsoft so it can be sorted out...

Tourist
Posts: 1

Re: MIcrosoft Teams not showing GoPro as a device

[ New ]

Did you get an answer for this? I'm having the same problem. 

Sightseer
Posts: 1

Re: MIcrosoft Teams not showing GoPro as a device

[ New ]

I'm also having this issue. Teams (Mac) is reporting this as its version:

 

You have Microsoft Teams Version 1.3.00.18164. It was last updated on 8/13/20

 

It's showing up in all of the other programs I have that use webcams - OBS, ManyCam, and QuickTime.

Sightseer
Posts: 1

Re: MIcrosoft Teams not showing GoPro as a device

[ New ]

I have the same issue where it doesn't work in native Mac client of MS Team. Have updated GoPro Hero 8 to latest Webcam version 1.0.220. Mac MS Teams is running 1.3.00.21953. It was last updated on 8/18/20. I also tried reinstalling Teams. 

 

The GoPro works fine with MS Teams Web as well as Google Meet (in Chrome). 

Sightseer
Posts: 2

Re: MIcrosoft Teams not showing GoPro as a device

[ New ]

I'm having the same issue.  Using latest firmware and update from GoPro, Teams version is latest on Mac as well as of 9/5/2020.

Sightseer
Posts: 2

Re: MIcrosoft Teams not showing GoPro as a device

[ New ]
Solved. Copying from this post on the Microsoft Forums. At least until Microsoft fixes this in an update, this is confirmed to work.
https://answers.microsoft.com/en-us/msteams/forum/all/microsoft-teams-mac-os-client-is-not-recognizi...

----

I had the exact same thing happen to me after updating to the latest version of teams. However, I was able to come up with a solution that resolves the issue entirely. It has to do with how Apple is starting to codesign specific apps to block 3rd party CoreMediaIO plugins. If we remove that codesigning, then it will allow those 3rd party plugins to function again.

The fix is pretty simple. First, completely exit out of Teams, then open Terminal and issue the following commands:

If you havent installed xcode previously, first run:

xcode-select --install

Then, run:

sudo codesign --remove-signature "/Applications/Microsoft Teams.app"

and:

sudo codesign --remove-signature "/Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app"

Once you've issued those commands, open up Teams. It should ask you for an administrator password to allow the (now) unsigned application to access your keychain. Once entering your password and selecting, "Always Allow", the issue should be resolved. (At least until the next update to teams is released).