Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Tourist
Posts: 2

when I click on view media it doesn’t do anything, it loads then goes back to the same screen.

[ New ]
My camera says connected, and when I click view media it says loading then brings me back to the same thing. I deleted the app then re downloaded it and it still doesn’t let me view my photos/videos. I turned the camera off and closed out the app many times and still can’t view anything.

Accepted Solutions
GoPro
Posts: 12,598

Re: when I click on view media it doesn’t do anything, it loads then goes back to the same screen.

[ New ]

Hello @fleetlight70275. Please make sure your mobile device, app, and camera are on their current versions.

What's the GoPro camera used? Please try to unpair and re-pair your camera to the app. Also, see if changing the camera's Wi-Fi Band from 5ghz to 2.4ghz and vice versa will make any difference.

Let us know how it goes.

View solution in original post


All Replies
GoPro
Posts: 12,598

Re: when I click on view media it doesn’t do anything, it loads then goes back to the same screen.

[ New ]

Hello @fleetlight70275. Please make sure your mobile device, app, and camera are on their current versions.

What's the GoPro camera used? Please try to unpair and re-pair your camera to the app. Also, see if changing the camera's Wi-Fi Band from 5ghz to 2.4ghz and vice versa will make any difference.

Let us know how it goes.

Sightseer
Posts: 3

Re: when I click on view media it doesn’t do anything, it loads then goes back to the same screen.

[ New ]

So what's now did you fix your issue?

Tourist
Posts: 2

Re: when I click on view media it doesn’t do anything, it loads then goes back to the same screen.

[ New ]
yes I fixed the issue, thank you.