Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Highlighted
Tourist
Posts: 2

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

I also have the same problem. I tried streaming via rtmp, but also to no avail.

Highlighted
Tourist
Posts: 9

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

Same problem here with YouTube live streaming.

 

I also have the annoying connection problems described in Matthias' video.

 

https://www.youtube.com/watch?v=EOJQSAv1_pY

This is a oneshot video to show the whole process and all the integrated problems I experience while trying to do a live streaming session with the GoPro Her...
Highlighted
GoPro
Posts: 13,118

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

Hello @sanchezik. and @sprystorm60232. To verify, do your accounts have at least 1000 subscribers as explained here?

 

The video from @matthiask5 showed a number of issues with the live streaming process. Among which are (1) connectivity, and (2) not getting the actual stream displayed on the YouTube page. 

 

Do you also experience having to reconnect the camera and the app multiple times before you are able to get to the streaming page? Make sure that you have the latest version of the App installed, that your device is running on the latest OS and that your HERO8 Black camera is updated to the latest firmware. 

 

Also, see the suggested troubleshooting steps above. Let us know what you find out. Thanks!

Highlighted
Tourist
Posts: 2

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

[ Edited ]

I don't have 1000 subscribers, but it's not necessary for streaming via youtube. I can easily stream to YT directly from the camera connected to the laptop or from the program OBS Studio, so this is some other problem. I use the latest version of the gopro application for android and the latest firmware (1.60). In the application and in the camera everything is fine, if I change the name of the streaming in the application, I see this new name also in YT, but is still no streaming in YT.

Highlighted
Tourist
Posts: 9

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

I can live without streaming to YouTube if I have to, but the connection problems are annoying.

 

* iPad (6th Gen) 13.4

* Camera version 01.60.00

* App version 6.8 (3549)

 

After an rtmp stream to a custom server (which works!), I can reliably connect to the camera from the app with the following steps:

 

0. Exit app
1. Preferences > Connections > Reset Connections
2. Wait a bit
3. Preferences > Connections > Wireless Connections > On
4. CONNECT A NEW DEVICE: Connect
5. Start app
6. In the app: Connect Your GoPro
7. Connect Device > GoProApp
8. Bluetooth Pairing Request > Pair (do not wait too long to confirm)
9. Wait
10. Connect to Wifi Network: Okay
11. Success!

 

Of course, I now have to re-enter the Wifi credentials (and always the rmtp URI) in the app again.

Highlighted
GoPro
Posts: 13,118

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

@sanchezik. The setup you describe works with streaming without 1000 subscribers. YouTube has restrictions (in terms of subscribers) when live streaming is through mobile applications like the GoPro App. See https://support.google.com/youtube/answer/2853834?hl=en for reference. 

Highlighted
GoPro
Posts: 13,118

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

Thank you for sharing, @sprystorm60232. The connectivity between the camera and the app should be able to last for up to 8 hours after being idle. The current version of the GoPro App is 6.9. Please update to this version and see if the connection process will be improved. Let us know how it goes. 

Highlighted
Tourist
Posts: 9

Re: YouTube Live Streaming with Hero 8 not working even with 1000 subs and YT activation green

I can confirm that with app version 6.9.1 and the iPad software update to 13.4 I can connect more reliably.

 

Thanks!

 

Still, after finishing a custom RTMP stream, I have to go through steps 0 - 11 to reconnect.

 

An it looks like the camera automatically switches to the Wide lens (or the SuperView lens) when I start the stream.

 

Is that a bug or did I miss some configuration option?