Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Highlighted
Tourist
Posts: 3

WiFi problem Hero8

As soon as i want to preview the camera stream the wifi connects fine and i can see the preview. Some seconds later there is a popup from androit telling me that this wifi has no internet connection. When i accept this the stream is dead. I could not find a way to disable this. My phone is a huawai p smart 2019 with android 10. a feature where i just could get the wifi conection by choise and not only when i start the preview might help. Thank you for your help in advance! Happy Greetings, yannik
Highlighted
Tourist
Posts: 3

Re: WiFi problem Hero8

I have the same issue
Screenshot_20200601_182648_com.android.settings.jpg
Highlighted
GoPro
Posts: 15,283

Re: WiFi problem Hero8

Hi @yah27833 @yah27833

 

Please go over the information below:

 

Android Specific Tips

Network Rating Provider 
Beginning in Android 8.1, operating systems started to include advanced Wi-Fi settings intended to attribute a quality rating to accessible networks, save your preferred and known connections, and switch you to a stronger one automatically. This feature may cause issues connecting or reconnecting to your GoPro, because it categorizes your camera as a lower-quality access point. In order to remedy this issue, navigate to Settings > Network & Internet > Wi-Fi Preferences > Advanced > Network Rating Provider. Select None and attempt to connect/reconnect to your GoPro camera.

Smart Wi-Fi / Wi-Fi+
Similar to Network Rating Provider, some Smart Wi-Fi implementations categorize the Wi-Fi networks broadcast by your GoPro camera as having poor signal. Because of this, certain Smart Wi-Fi features need to be disabled. Follow these instructions to do so:

  1. Disable “Smart Network Switch” or “Auto Network Switch” from the phone’s Wi-Fi settings.
  2. Go to: Wi-Fi Settings > Advanced > Disable “Smart Network Switch” or “Auto Network Switch.”

Huawei-Specific Troubleshooting

  1. Disable Wi-Fi+ from the device’s Wi-Fi settings screen.
  2. Turn ON location services (GPS) on your phone before connecting your camera.
  3. Navigate to Settings > Advanced Settings > Location Access > Access My Location. 

Let us know how it goes.

 

Thanks!

Ej

Highlighted
Tourist
Posts: 3

Re: WiFi problem Hero8

Unfortunately this doesent help. Im in contact with the huawei service team. I can not acess the advanced wifi settings due to emui 10.0? Key problem ist this **bleep** popup...
Highlighted
Tourist
Posts: 3

Re: WiFi problem Hero8

[ Edited ]

Bonjour,  

J'ai partiellement résolu le problème.

Lorsque le "pop-up" apparait, il faut  répondre  "se connecter" après lorsque ça  fige,  cliquer sur le menu des options (clé à molettes) puis bouton "terminer"  en haut à droite. Cela entraine un retour vers l'apercu et cela devient fonctionnel.

 

Popur info, je suis aussi chez Huawei et la solution précédente n'a  pas fonctionnée non plus.

Highlighted
Tourist
Posts: 3

Re: WiFi problem Hero8

[ Edited ]

 

Hello, I partially solved the problem. When the "pop-up" appears, you must answer "connect" after when it freezes, click on the options menu (wrench) then button "finish" at the top right. This leads to a return to the overview and it becomes functional.  

 

FYI, I'm also at Huawei and the previous solution didn't work either.

-------------------------

Bonjour,

J'ai partiellement résolu le problème.

Lorsque le "pop-up" apparait, il faut répondre "se connecter" après lorsque ça fige, cliquer sur le menu des options (clé à molettes) puis bouton "terminer" en haut à droite. Cela entraine un retour vers l'apercu et cela devient fonctionnel.

 

Pour info, je suis aussi chez Huawei et la solution précédente n'a pas fonctionnée non plus

 

@aragon1006  @yah27833 

 

Highlighted
Tourist
Posts: 3

Re: WiFi problem Hero8

Thanks for the workaround! Works fine for me. For sure this has to be fixed, but im happy to finaly use the app as intended.