Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Tourist
Posts: 5

Trim no longer working in app

[ New ]
I have been using the trim feature in the app and when the latest update came (Adding the GPS stickers) trim no longer works.
I have a gopro hero 7 black updated to the latest firmware 1.61. Problem existed before and after updating the firmware.
I can download a clip without trimming it using the app fine.
GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Hello @sweetpeak64011

 

Thank you for the feedback. Which mobile phone are you using? Which version of the app do you have installed? Were you getting any error message while attempting to trim? We tested with Samsung phones and we were able to trim sample videos and save them to the phone gallery without any issue. Try uninstalling then re-installing the app and make sure that your device has ample memory space. Let us know how it works out 

 

Thanks, 

Marius

Tourist
Posts: 5

Re: Trim no longer working in app

[ New ]
Hi @mariustanya,

Thanks for the reply. I am using app version 5.1 (7716) on a Samsumg A5 2017. The message was just an error occured while trying save your video nothing specific. I have tried reinstalling the app and resetting the connection and get the same message. I have 2+gb space on both my phone internal memory and the GoPro.

Pete
Tourist
Posts: 5

Re: Trim no longer working in app

[ New ]
@mariustanya, the exact message I get is "There was a problem preparing your video"
GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

 

Hi @sweetpeak64011

 

Do you still remember what resolution/ fps used?

Were you able to test the camera with a different phone?

 

 

Thanks!

Ej

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]
I am getting the exact same message. Running 5.1 GoPro app and Android 7.1.1 on a Lenovo tablet
GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

Hi @tdoyle9871

 

I have just tested an Android phone running on 7.0 and 8.0.

Both allowed me to trim videos without any issues.

Is this happening to one recording only or to other video files as well?

Have you tried to uninstall then reinstall the app?

So we can assess the issue further, are you able to send a screen recording on whats happening when you attempt to trim the videos?

 

 

Thanks!

Ej

 

 

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]

The problem is with all of the videos that I have uploaded to my Lenovo tablet with GoPro Quik key. I uninstalled and reinstalled the GoPro app and have rebooted the tablet multiple times.

 

I have attached a screenshot of the error message 

20181228_103535.jpg
GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

 

Hi @tdoyle9871

 

Are these chaptered videos?

To help isolate the issue further, kindly try to replicate the issue on another mobile device.

 

Thanks!
Ej

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]
They are not chaptered videos. They range in length from 20 seconds to 3 minutes. I have also updated the Android software on the tablet to 8.1. I have tried to shoot lower resolution and frame rate (720 & 30fps from 1080 & 60fps) without any luck

I do not have the same problem on my Galaxy 7 phone. I would strongly prefer to work of the tablet given the much larger screen and storage space.
GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

 

Hi @tdoyle9871

 

To isolate the issue further, would you mind shooting some test files then have it transferred via the GoPro app instead of the Quik Key.

See if the same happens.

 

 

Thanks!

Ej

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]

The same message happens when transferring without the quik key.

 

For furtther info - I am able to trim videos and play the trimmed video in the editing window, but when I attempt to save the trimmed video is when the error message pops up. Therefore, there is no way to save the trimmed videos.

GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Thank you for the update, @tdoyle9871. It seems that the behavior is isolated to specific devices. We aim to ensure that the app works on every device but this is nearly impossible due to the nature of the OS. Android is a fragmented OS, with devices running on different specs. These inconsistencies make it difficult to ensure that the app works flawlessly on every device.

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]

While I appreciate that fragmentation is an issue with Android OS, I don't beleive that is the case here. Both the Galaxy phone I tested this on where it works and the Lenovo tablet where it does not work are running the same version of Android. As far as I can gather there is very little customization from either manufacturer - so it is as near to an apples to apples comparison as possible. Lenovo tablets are quite widespread; and as such, I'd recommend more digging from GoPro's technical team.

GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

 

Hi @tdoyle9871

 

This is noted and will be shared to the team in charge.

 

Thanks!

Ej

Tourist
Posts: 5

Re: Trim no longer working in app

[ New ]
If I uninstall and reinstall the gopro app. When I first start the app it has a gopro hero 3 listed which I used to own. Before uninstalling the app I had deleted this and added the hero 7 that the problem is with. These settings that aren't deleted possibly from am older version of the app might be causing related to the issue.

Pete
Tourist
Posts: 5

Re: Trim no longer working in app

[ New ]
I have tried downloading the app onto another device and still cannot videos to save trimmed. It did not get as far as an error mesaage though. I also came across some layout issues and the trim save button disappearing issue though.

On the second device there is soft android controls (back, home and app switch are on screen) the trim, snapshot and download buttons are behind these controls in portrait mode and so are unusable. Secondly if I adjust the trim so the save button appears then change orientation the save button disappears until I readjust the trim. This seems to be a layout issue that other people are having in the reviews on Google play.
Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]

This is tangentially related to the topic at hand, but the GoPro Plus/GoPro cloud subscription would be endlessly more useful if user's could perform the basic trim and edit features available in the GoPro mobile app on videos stored in the cloud. The process of uploading to the cloud, then downloading to a device to edit/trim, and then back to the cloud is cumbersome and inefficient. It also has me increasingly questioning the value of the GoPro Plus subscription.

Sightseer
Posts: 1

Re: Trim no longer working in app

[ New ]
I am also having this issue. My device is a LG K20V 7.0 and my video lengths were equally as short. I hav shot at varios resolutions and frame rates, bit mainly 1080p and 24fps. I can trim jist fine, but trying to save to my device I get the same error message.
Tourist
Posts: 4

Re: Trim no longer working in app

[ New ]
Same trim issue / error message for me. Android 9. Xiaomi A1
Was working fine until new android app update / pie update
Tourist
Posts: 4

Re: Trim no longer working in app

[ New ]
A bit more info to add to my previous post. Mine is gopro 5 black
I've downloaded a clip to the phone. I've tried trim in the gopro app with that local clip. Different behaviour: it says it's done , the edit/ trim and comes up with blue check mark. However the 11 second trim is not saved properly. Show up as 1 second and does not play
GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Thank you for the update, @rockybeach86055. I tried trimming and saving on an Android 9 and was able to do it, both before and after import. The saved clips showed the correct video length as well. Which camera are you using and which firmware version does it have? Try uninstalling then re-installing the app and let us know if it helps. Thanks!

Tourist
Posts: 4

Re: Trim no longer working in app

[ New ]
My GoPro 5 black is on latest firmware 2.60
I've since remove latest app version and installed 4.5.2.
This is version before issue with photos from videos.
It also seems to be much faster to connect to the GoPro and access media on the unit.
GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

 

Hi @rockybeach86055

 

Just to clarify, did the trimming option work with the older version?

We always recommend the latest version of the app, but we'll have this shared with the ream in charge.

 

 

Thanks!

Ej

Tourist
Posts: 4

Re: Trim no longer working in app

[ New ]
Yep. It has always worked, up until recent version, as reported by others on this thread.
Thanks for looking into it.
To recap, trim with footage on camera = won't save select trim section.
Trim with footage downloaded to phone = it saved blank 1 second file
GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

 

Hi @rockybeach86055

 

We have a member who confirmed that uninstalling and reinstalling the app solved the trimming issue.

https://community.gopro.com/t5/GoPro-Apps-for-Mobile/Unable-to-trim-videos-in-the-app-with-the-lates...

 

Thanks!

Ej

 

 

 

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]

I have uninstalled and reinstalled multiple times and still have the same issue

GoPro
Posts: 27,018

Re: Trim no longer working in app

[ New ]

 

Hi @tdoyle9871

 

It should be working.

I have just tested a video file and was able to trim and save the clip. This is both on an Android and an iOS device.

 

 

Thanks!

Ej

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]

Attached is a screen shot of the same error message after uninstalling and re-installing the GoPro app again.

gopr.jpg
GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Hello @tdoyle9871 . Is it GoPro App version 5.1.1 that is installed on your device? Are you still having the issue only on your Lenovo device? Check and make sure that it is updated to the latest OS version as well. Please keep us posted. Thanks!

Hiker
Posts: 19

Re: Trim no longer working in app

[ New ]

Yes. I am running 5.1.1 for the GoPro app and Android 8 for the Lenovo tablet. The issue is on the Lenovo device. I have not had issues on my Samsung Galaxy S7 phone. I'd strongly prefer to use the Lenovo tablet to edit due to the larger screen size and larger internal storage space (since the GoPro app does not allow a user to save videos to an SD card)

GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

This is noted, @tdoyle9871. Well pass this along to the team. We're working on full support for Android devices and many others in the future. We will keep you in the loop for updates. Thanks!

Hiker
Posts: 7

Re: Trim no longer working in app

[ New ]

I also have this problem on a new Lenovo tabled tunning Android 8.1, App 5.11. There is plenty of free storage. The error message is very generall and not a all helpful, is there anything that should be checked? Where would the app store the trimed video? Anything that would indicate what could be going wrong would be helpful.

GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Thank you for sharing, @richardd351. There seems to be an issue on trimming via GoPro App on some devices only. We have reported this to the team and we are still waiting for a feedback. We will keep you in the loop once we have new information. 

Tourist
Posts: 5

Re: Trim no longer working in app

[ New ]
The same issues described with video trimming and saving the clips to my phone are happening with my Samsung Galaxy Note 9. after the recent update is when the issue began and had conjured after multiple uninstalls and reinstalls of the GoPro app and reset of the Hero 5 and Hero 5 session.
Tourist
Posts: 4

Re: Trim no longer working in app

[ New ]

I'm having the exact same problem.

Using Samsung S9, GoPro Session 4.

Before the update it was working perfectly, with the same configuration.

 

Tourist
Posts: 2

Re: Trim no longer working in app

[ New ]

Just adding to the list. Same error. Videos 1080p 120fps

Go pro Hero 6 Black.

Google Pixel 3. Android 9

I can't save trimmed vides from GoPro Android App 5.1.1

 

Was working fine, on a Moto X4 Android 8.1

GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Hello Everyone. A new version of the GoPro App for Android (v5.2.1) was recently released. If you have not tried it yet, please see if the new app clears out the issued with trimming and saving. After you install the new version, or update to it, restart your device then pair it with the camera again. We'd love to hear back from you. Best regards! 

Explorer
Posts: 13,045

Re: Trim no longer working in app

[ New ]
LG v30 (Android) with latest app release (uninstalled and reinstalled today). Trim feature is not working. I can access trim and press the check mark, but no option to save is given. Forced to discard changes to move on from clip.
Tourist
Posts: 5

Re: Trim no longer working in app

[ New ]
I just uninstalled and then reinstalled the GoPro app and the video editing/trim feature is now working. I am able to edit and save the video clips. Thank you for correcting the issue. Galaxy Note 9
Tourist
Posts: 4

Re: Trim no longer working in app

[ New ]

I'm not able to trim with the new 5.2.1 app and my Hero 6 Black with latest firmware. I have a Galaxy Tab E 32GB (T378V) with Android 8.1. I have tried uninstalling, restart tablet, reinstall app, restart tablet, and sync to gopro several times and I can never get passed the part where you save the trim. I click the save button and then select save to app and it just sits at 0% forever. I've tried multiple videos from multiple sd cards and it never works. My wifes Galaxy S7 phone however works just fine every time with every video.

 

Something else I noticed is I'm unable to click the button to save a screen grab from the video it just sits on the screen with the spinning circles and never does anything. If I select a video and click the button to download the video to the tablet it copies for several minutes and completes just fine. I can then go in the app and see the video and it's length on the tablet, but it just shows a black screen instead of a pic of the video. Clicking on the video doesn't play anything. If I select that video again and select save to phone it copies to my tablets gallery and shows up as a black video with the correct size and length but doesn't play anything in vlc. It's like my tablet can play the lowres preview just fine, but doing anything with the hires copy of the file my tablet can't seem to read the file. If I pull the sdcard out of the gopro and put it directly in my tablet, vlc opens the same video files just fine. The videos play very choppy because my tablet has a slow processor, but that is to be expected

 

All of my videos are recorded at 2.7k 60fps and linear FOV with gps off. I did a factory reset to the gopro and the recorded a 20 second video. I tried doing a trim on that video and when I get to save instead of sitting at 0% forever it shows 0% but immediately says Let's try that again There was a problem preparing your video. If I copy that new short video to my tablet it this time shows a screen shot of the video instead of the black screen, but the trim still fails at 0% with the immediate error message above.

 

So in conclusion...

A 20 sec fresh factory reset video which is 1080p shows a picture of the video, stops at 0% with an immediate error message.

A 2.7k 60fps video 1 min long shows a black screen and sticks at 0% forever with no error message.

All videos play fine on my wifes Galaxy S7, and play when the sdcard is put directly in the tablet.

GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Great to know that it is working for you, @jonnywhy26 . Thank you for the feedback, @danielr15 and @kenmerritt. Is this the same behavior even after restarting your phone? 

Tourist
Posts: 4

Re: Trim no longer working in app

[ New ]
Yes I've tried restarting everything multiple times.
GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Thank you for the quick reply, @kenmerritt. This is noted. 

Hiker
Posts: 7

Re: Trim no longer working in app

[ New ]

I've tried 5.2.1 on Lenovo tablet running Android 8.1. I get new options to "Save copy to phone" or "Save copy to app gallery" but both throu the same error as before. The error comes up at 0% so is likely to be something to do with where the clip is being saved to. Given some people are having better luck this looks like an initialisation error. Any way of installing an older version that might get teh initialisation correct?

Explorer
Posts: 13,045

Re: Trim no longer working in app

[ New ]

@mariustanya 

My LG v30 phone is on Android version 8.0.0

I have deleted the app, restarted my phone, reinstalled the app, and restarted the phone (in that order) and it's still not working (trim + save).  I can Trim and add performance stickers, but just not save once done.

GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Our team has been made aware of your feedback, @richardd351 and @danielr15. Thank you for sharing.  We observe that the issue does not happen with all phone models/device OS so we are still working with the team to further isolate cause. The information you provide helps a lot. 

GoPro
Posts: 19,611

Re: Trim no longer working in app

[ New ]

Hello @danielr15 , @richardd351, @kenmerritt, @wooleyje, @martimfogaca . While already using version 5.2.1 of the GoPro App, please check if you will be able to save trimmed videos, or those with GPS performance stickers after clearing cache in App settings (only clear cache, please do not clear/delete data). We hope to hear back from you. Many thanks!

Explorer
Posts: 13,045

Re: Trim no longer working in app

[ New ]
This worked for me 😁
Tourist
Posts: 2

Re: Trim no longer working in app

[ New ]
All good for me now. It started working when the app updated a few days ago. Thanks