Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see if it is on our Update page.
GoPro Apps for Mobile
Reply
Tourist
Posts: 4

Screen grabs from video won't export

[ New ]

I am very frustrated! I spent a bomb of money on the GoPro Hero 10 so I could take screengrabs from 5k video, but it won't work.

 

I am shooting on GoPro 10, uploading and using the Quik app on Samsung S20 FE 5G running Android 11 (so all up to date).

 

When I go into the video to take a screen grab using the button at the bottom of the app as per GoPro's instructions, it will give me a tick on the screeen and say "saved to app gallery". When I go to the app gallery to look at the photo, each time it will export only a black square. If I try a different frame from the same video, or even a different video, I get the blue tick and it says "skipping duplicates". The only image in my gallery is a black square.

 

Why is this not working, and all that is being saved is a black square??? I am VERY frustrated!!!

GoPro
Posts: 3,688

Re: Screen grabs from video won't export

[ New ]

Hi,

5K videos are huge files, that's probably what's happening here, your phone doesn't manage.
I tested on my end with my Note 10 and a 11 sec 5.3K/25 video. I can't frame grab if the video is still on the camera but when I get the video to my app, the frame grab is correct.
A coworker also tested on S20 with 5.3K video and it worked also.

Is there anything in particular, what steps do you do exactly? You are downloading the media from camera to app?
Do you have the same result trying with a 4K video?

Tourist
Posts: 4

Re: Screen grabs from video won't export

[ New ]

Hi haindash,

 

Thanks for a quick reply.

 

Yes, when I shoot in 4k, I am able to take a screen grab. 

 

If I shoot in 5.3k, I am not able to take a screen grab. I have screenshots of the process:

 

Screenshot_20211203-083600_GoPro Quik.jpgScreenshot_20211203-083611_GoPro Quik.jpgScreenshot_20211203-083619_GoPro Quik.jpgScreenshot_20211203-083629_GoPro Quik.jpg

 

If you're telling me the reason that I can't take screen grabs from 5.3k resolution is because my phone can't handle it, I'm very disappointed that GoPro doesn't advertise the minimum phone/processor/RAM specs to be able to do so. I can already shoot 4k60 videos on my phone, so now I have a very expensive camera that I literally don't need. My phone is a 2020 model, so it's hardly behind the times. 

 

I was also able to take screengrabs before you rolled out the new app update a couple of weeks ago. What has changed between now and then?

 

I have already tried closing all my apps to free up space to take the screengrabs in 5.3k, and it still won't work. Is there anything else I can do to be able to take screengrabs from 5.3k video?

GoPro
Posts: 3,688

Re: Screen grabs from video won't export

[ New ]
Hi,

Thank you for the screenshots.
So we had a bug recently - which actually was caught before the release so it wasn't even in production - where frame grab would be black. That kind of bug happened regardless of the device and regardless of the resolution.
The issue here is that my Note 10 doesn't repro, my coworker S20 doesn't repro and it does work on 4K. This will lead me to say that it's a device specific issue.
When you said it was working before the update, do you mean with the exact same 5K files? That part is indeed strange.
What kind of 5K file are we talking about, is that a 30 sec file, a 30 min file?
GoPro
Posts: 3,688

Re: Screen grabs from video won't export

[ New ]
Do you know the chipset on your phone?

Another coworker gave this a try with OnePlus and S21 with 5.3 / 4K / various fps and wasn't able to reproduce that black screen issue.
GoPro
Posts: 47

Re: Screen grabs from video won't export

[ New ]

Hello,

 

First of all sorry for this issue that you are seeing.  I finally managed to reproduce it after many attempts (over 20 tries).  The issue seems to be random, but we will look into it now that we managed to reproduce it in house.  

 

Can you try this workaround which worked for me?  Delete the black frame from the app tab in the app and try to grab the same exact one again (so you do not get the duplicates skipped message).  Please let me know if it works for you this time.

 

Thanks,

Jason

GoPro
Posts: 3,688

Re: Screen grabs from video won't export

[ New ]
Can you confirm one quick thing: you are trying to frame grab from the camera roll of your GoPro or did you first download the file to the app and then frame grab?
Tourist
Posts: 4

Re: Screen grabs from video won't export

[ New ]

Yes, I could take screengrabs of 5.3k video before the latest update. All my videos are under 30 seconds, most about 10 seconds. 

After the update, if I try and take another screengrab from the same video, it comes up with a black square.

Tourist
Posts: 4

Re: Screen grabs from video won't export

[ New ]

@haindash 

Yes, I could take screengrabs of 5.3k video before the latest update. All my videos are under 30 seconds, most about 10 seconds. 

After the update, if I try and take another screengrab from the same video, it comes up with a black square.

 

My phone specs are:

 Qualcomm Snapdragon 865

  • CPU Speed
    2.8GHz, 2.4GHz, 1.8GHz
  • CPU Type
    Octa-Core
    • RAM Size 
      6
    • ROM Size
      128

     

    I don't understand your question about grabbing the frame form the camera roll of my GoPro or downloading the file to the app and then doing the frame grab? I'm doing the steps I outlined above with the screenshots I posted. I assume this is grabbing the frames from within the app. Can you confirm? Is there another way to do it that might work??

     

    @superdusk1104 
    I'm glad you've managed to reproduce the issue and I'm not going insane!! Though I'm surprised you only get the black square intermittently as I get it constantly. Yes, I have already tried deleting the black square from the app gallery, so I don't get the "duplicate skipped" message. Every screen grab on 5.3k still comes up as a black square. Do you have any other suggestions of what I can do?

     

     

    Thank you to both of you for your help on this so far. Honestly, this app has had so many issues and I've lost so much time and frustration over this and other problems that I'm very close to sending back my GoPro for a full refund. I'm also having issues with video export, colour adjustment in the app, slow-mo, and trimming video at the right spot. Also, occasionally when frame grab does work at 4k resolution, it will select the frame either before or after the one I'm trying to choose. I appreciate your help with working through this. And please let me know if there's any way I can roll back to the previous version of the app, or if you can offer it on google play.

GoPro
Posts: 3,688

Re: Screen grabs from video won't export

[ New ]
@katew16
Hi,

Thank you for the detailed information. I was trying to know if the video was still on the camera when you were doing a frame grab or if you had first downloaded the video to your Quik App (which I think is this one)

I can send you a debug version of the app = it's the same version but it can get us logs.
I will send you an email at your gmail address on how to proceed.
GoPro
Posts: 3,688

Re: Screen grabs from video won't export

[ New ]
Hi @katew16

I've sent you an email to your gmail address to see if you could help us out with logs.

One little question, just to be sure:
Are you able to play the 5K file correctly / is the 5k file fully loaded when you do the frame grab?
Is that black frame situation the same regardless of the 5K file, like if you made a brand new file, it's the same?

Let me know if you did get my email if I can assist you with the steps.
We can also chat per Messenger - Anais GoPro - if it's easier.