Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Sightseer
Posts: 1

My Hero 7 black used to connect to the app, but now will not. Have tried every fix listed.

[ New ]

My Hero 7 black used to connect to the app very well. Now it will not connect at all. If I delete the camera and search for "new camera" it will look and find my GoPro listing it by name. Then the GoPro itself will say "connection successful" on the screen.Then a message comes up stating it is searching for "device to use with gopro" in which it finds no device. WHAT DEVICE? is that the phone or the camera or something else? After that constant messages about a potential wi-fi issue or that the app has cancelled the request to choose a device. 

 

This is highly frustrating as I thought I would update the camera, but I have to do that ON THE APP! I have tried all of the "fixes" listed. Restarting everything. resetting to factory, clearing the camera from the bluetooth and wi-fi lists, etc. Please help I love the camera, but this app thing is seriously rediculous. 

 

GoPro App version - 7.0.1
Camera model and firmware version - HERO7 Black v1.90
Phone Model - LG-V35
Mobile OS - Android 10


Accepted Solutions
GoPro
Posts: 27,179

Re: My Hero 7 black used to connect to the app, but now will not. Have tried every fix listed.

[ New ]

Hi @adeptflash124

 

Try manually connecting to the camera's WiFi network.  Send the app to the background and manually connect to the camera from your phone’s WiFi settings. You can find the password by putting the camera in pairing mode, then tapping the Info button on the camera.

 

You may also try changing the Wi-Fi Band to 2.4GHz.

 

Let us know how it goes.

 

Thanks!

Ej

View solution in original post


All Replies
GoPro
Posts: 27,179

Re: My Hero 7 black used to connect to the app, but now will not. Have tried every fix listed.

[ New ]

Hi @adeptflash124

 

Try manually connecting to the camera's WiFi network.  Send the app to the background and manually connect to the camera from your phone’s WiFi settings. You can find the password by putting the camera in pairing mode, then tapping the Info button on the camera.

 

You may also try changing the Wi-Fi Band to 2.4GHz.

 

Let us know how it goes.

 

Thanks!

Ej