Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Tourist
Posts: 3
Accepted Solution

Hero 5 Connecting to Android App

This is maddening.  I'm trying to connect my Hero 5 Session to the Android app.  I follow the instructions, however the instructions don't match the actual camera read out.  For example, instructions say to press menu button until you see CONNECTION SETTINGS.  Well guess what, CONNECTION SETTINGS DOES NOT EXIST on the camera.  I do find Select Control and it has the word "App" under it.  I try that and it tells me to put the app in pairing mode.  There is no "pairing mode" in the app.  If I click continue in the app it tells me to hit the shutter button to select "CONNECT NEW DEVICE".  Once again, this phrase DOES NOT EXIST!!!!  

 

This is pretty frustrating.  I got the camera for my birthday and would really love to use it.  Would be nice if the instructions provided actually matched!!!!


Accepted Solutions
Tourist
Posts: 3

Re: Hero 5 Connecting to Android App

Hello Ryan,

 

Thanks again for your reply.  First and foremost, I got it working!!!  The manual update helped, however I would like to mention that the GoPro website could use a little more user friendly interface.  Something that makes it easier to point and click to where you want to go.  As you mention, the update site defaults to one particular camera, however it's not very intuitive.  If you could pass that along to the "powers that be" that would be great!  

 

Also, in getting the camera linked, I kept getting an error message asking for the "password".  Well, I had never known of a password for the camera so I went and grabbed the manual online and found the default was "goprohero".  I entered this password in the app and it told me this was incorrect.  I tried again, same result.  At this time, I went into the the wifi section of my phone and clicked on the camera that was showing.  It prompted me for my password and I entered the default and bingo, I was connected!  I flipped back over to the app and at this point it was asking me for the pin.  Kind of odd that I couldn't enter my pw in the app, but I got it to work nonetheless.

 

Thank you again for your assistance and you can consider this one closed!

 

Larry

View solution in original post


All Replies
Highlighted
GoPro
Posts: 3,924

Re: Hero 5 Connecting to Android App

Hi @larryf07,

 

I am sorry to hear you are having some trouble getting connected to your camera. Check out this article to get you up and running!

 

https://gopro.com/help/articles/Solutions_Troubleshooting/Capture-Camera-Connection-Troubleshooting

 

Hope that helps.

 

Cheers,

Ryan

Tourist
Posts: 3

Re: Hero 5 Connecting to Android App

[ Edited ]

Thank you for your response, however this is not addressing my issue.  I open my wifi on my phone and I can see the camera, however when trying to connect to the wifi, it's asking for a password.  The camera provides a 4 digit pin, however this is not long enough as the wifi password requires at least 8 digits.

 

OK, to make matters even more frustrating, I decide to attempt to update the software.  I'm prompted to update through the app, which of course I can't do since I can't connect it to my phone so I opted for the "manual" update option.  In doing so, I'm asked to enter my cameras serial number.  It tells me it's not valid?  Seriously?  It's 14 digits, it's taken directly off the label on the inside of the side door!  It's almost like GoPro doesn't want me to use my camera.  I'm not technially daft.  Good lord, I work with tech all day!  I have wifi on my coffee brewer!  I know what I'm doing, so what the hell is wrong here?  For the record, if there are any actual GoPro staff here, this is my serial number that I'm told is not valid.  [EDIT]  I took a picture of the serial number.  Is that not it?

GoPro
Posts: 3,924

Re: Hero 5 Connecting to Android App

Hi @larryf07,

 

The Password and Pin number are going to be two different things. It sounds like there is an issue with the current version of firmware on that camera so the first thing you will need to do is get it manually updated. 

 

When trying to manually update make sure you are on the correct landing page for your camera. The site will default to HERO5 Black. In addition the serial number that you have provided is for a HERO Session not a HERO5 Session. 

 

If you are still having issues getting that serial number to be accepted to the site then it is most likely related to the autofill function that browsers have to save past information when putting it in information. If at some point the information was entered incorrectly by accident then the browser will not let you put in the correct serial number, because it is overriding the correct info that you are putting in.

What I would suggest is try to use a "Private Window" or "Incognito Window." Make sure to clear your history, cookies, and cache in the settings of your browser, then try again. Make sure that when you put that information in it starts with C314 and is 14 digits long. 

 

Hope that helps.

 

Best,

Ryan

Tourist
Posts: 3

Re: Hero 5 Connecting to Android App

Hello Ryan,

 

Thanks again for your reply.  First and foremost, I got it working!!!  The manual update helped, however I would like to mention that the GoPro website could use a little more user friendly interface.  Something that makes it easier to point and click to where you want to go.  As you mention, the update site defaults to one particular camera, however it's not very intuitive.  If you could pass that along to the "powers that be" that would be great!  

 

Also, in getting the camera linked, I kept getting an error message asking for the "password".  Well, I had never known of a password for the camera so I went and grabbed the manual online and found the default was "goprohero".  I entered this password in the app and it told me this was incorrect.  I tried again, same result.  At this time, I went into the the wifi section of my phone and clicked on the camera that was showing.  It prompted me for my password and I entered the default and bingo, I was connected!  I flipped back over to the app and at this point it was asking me for the pin.  Kind of odd that I couldn't enter my pw in the app, but I got it to work nonetheless.

 

Thank you again for your assistance and you can consider this one closed!

 

Larry