Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Tourist
Posts: 2
Accepted Solution

Gopro app pairing

I have trouble pairing my gopro hero 7 black with my phone, I find the gopro on the app and it says connected but it won't find the media or see what the gopro see on the Samsung s9 pluss. I have tried changing the Wi-Fi band from 5ghz to 2,4 but it did not work. There is no problem connecting to an iPad, but won't work with the to Samsung phones I have tried with. I have reset both the app and the camera, please help

Accepted Solutions
GoPro
Posts: 3,883

Re: Gopro app pairing

Hi @eirike3445,

 

Sorry about that.

 

Have you tried checking if your camera is looking for available Wi-Fi with internet connection?

That might be the problem since the camera don't have internet. 

 

Please check your settings and before you pair it make sure that the phone is just connected to the camera and won't pair to nearest Wi-Fi with internet. 

Also try to switch from 2.4 to 5ghz or 5ghz to 2.4.

 

Disable smart network switch on your phone. 

It's on your Wi-Fi settings. 

 

Regards,

-Jay 

View solution in original post


All Replies
GoPro
Posts: 10,259

Re: Gopro app pairing

 

Hi @eirike3445

 

When you did the reset on the camera was it to factory settings or the Wi-Fi settings?

If you have not reset the Wi-Fi settings, please go ahead and reset it. Preferences > Connections, and then tap Reset Connections.

Once done, get your camera to pairing mode.

If it's still not pairing, go to your phone's connection settings then forget the Bluetooth ID.

 

For reference: Troubleshooting GoPro App Connectivity Issues

 

Thanks!

Ej

Tourist
Posts: 2

Re: Gopro app pairing

I reset the wifi settings, I did what you said about forgetting the bluetooth settings. After a few tryes it worked, but only for one time. Now it won't connect to the Samsung s9 again. When I try to connect I get a exclamation mark on my wifi symbol on the phone. I also have a red signal light on sometimes after the gopro has been switched off, but disappear after taking the battery in and out. I am on vacation so to get the camera sync would have been amazing
GoPro
Posts: 3,883

Re: Gopro app pairing

Hi @eirike3445,

 

Sorry about that.

 

Have you tried checking if your camera is looking for available Wi-Fi with internet connection?

That might be the problem since the camera don't have internet. 

 

Please check your settings and before you pair it make sure that the phone is just connected to the camera and won't pair to nearest Wi-Fi with internet. 

Also try to switch from 2.4 to 5ghz or 5ghz to 2.4.

 

Disable smart network switch on your phone. 

It's on your Wi-Fi settings. 

 

Regards,

-Jay