Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Highlighted
Tourist
Posts: 2
Accepted Solution

GoPro Hero 7 Black and Android App disconnecting and error

First off, I'm a brand new GoPro user/owner. Just purchased my first GoPro this week.

 

Anyhow, I'm having some significant connectivity issues with my Galaxy S10/GoPro for Android app and my Hero 7 black. 

Maybe if I understood what and how the Gopro/Phone connect and the sequence of events I could get a better grip on this. Or if someone has any suggestions, please let me know. 

 

I have tried resetting everything per the Troubleshooting doc, but still see this issue. 

When I open my app and turn on my camera, I can "find" the Hero7 as shown in the photo. When I go to "control camera", the wifi drops and it switches to Data. Then after a lag, I will see Wifi return with an exclamation point showing me there is an issue with the wifi connection. I can control the camera at this juncture. 

As soon as I back out of camera control, I have to "reselect what device to use" again. This happens at every screen you back out of. You will see the wifi going on, to data, to another wifi over and over again. Sometimes when I back out, I'll get two or three error screens showing me there is a problem with WIFI connection, and it will send me to the troubleshooting page.

Now, on my wifi only tablet at home, I dont' have any of these issues. 

1.jpg2.jpg

3.jpg4.jpg

5.jpg6.jpg

2.jpg

Accepted Solutions
Highlighted
GoPro
Posts: 15,531

Re: GoPro Hero 7 Black and Android App disconnecting and error

Hello, @cturboaddict. The Wi-Fi symbol with exclamation is normal when the camera and the app are paired. This indicates that the connection is via Wi-Fi but not one with Internet connectivity. 

 

We just tested with an Android 10 device and a HERO7 Black and we were able to connect. We got the same screens that you have, except for the fourth one(4th photo). Once pairing is established, there was no issue observed with controlling the camera, accessing menu/settings, even media. 

 

If you haven't done it yet, see if manually connecting to the camera's Wi-Fi will make a difference. Send the app to the background and manually connect to the camera from your phone’s WiFi settings. You can find the password by putting the camera in pairing mode, then hitting the Info button on the camera.

 

 

View solution in original post


All Replies
Highlighted
GoPro
Posts: 15,531

Re: GoPro Hero 7 Black and Android App disconnecting and error

Hello, @cturboaddict. The Wi-Fi symbol with exclamation is normal when the camera and the app are paired. This indicates that the connection is via Wi-Fi but not one with Internet connectivity. 

 

We just tested with an Android 10 device and a HERO7 Black and we were able to connect. We got the same screens that you have, except for the fourth one(4th photo). Once pairing is established, there was no issue observed with controlling the camera, accessing menu/settings, even media. 

 

If you haven't done it yet, see if manually connecting to the camera's Wi-Fi will make a difference. Send the app to the background and manually connect to the camera from your phone’s WiFi settings. You can find the password by putting the camera in pairing mode, then hitting the Info button on the camera.

 

 

Highlighted
Tourist
Posts: 2

Re: GoPro Hero 7 Black and Android App disconnecting and error

Thanks, it looks like I'm connecting. It's just very clunky and not seemless. I'll get the hang of it, still new. 
Thanks for the help.