Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Posts: 1

Fusion + Pixel 3 Download Clip Issue

[ Edited ]

I have a gopro fusion (latest firmware or one version older I believe) and a Google Pixel 3 Running Android 9, and GoPro Android App Version 5.1.1. The phone seems to connect fine on the 5ghz band and I can view videos stored on the camera. The issue I have is when I try to download just a 33 second clip of the video I am previewing it gets about halfway through downloading and then just fails with no messege. It just goes back to the preview screen where I select the clip of video I want again. I have tried this at least 10 times. In between I have tried deleting the fusion from the App and phones bluetooth and reconnecting. I have also tried restarting the phone and I believe most of the other basic troubleshooting tasks. [Edit: the video I am trying to download the clip from is 5.2k 30]


This is very agrivating as I simply want to be able to try making an over capture video which is not supported on the desktop app and for some reason the fusion won't complete the download allowing me to work with the video on my phone.


For reference this same functionality works fine with a Hero7 Black and the same Pixel 3 phone. [Edit: the videos I've done this with on the Hero 7 have been 4k 30]

Posts: 15,305

Re: Fusion + Pixel 3 Download Clip Issue

Hi @pjg516


I did a test recording on a Fusion and transferred the file to a Huawei P9 (Android 7).

It took 4-5 mins for an 18-second Overcapture file.


Also tested a one minute Overcapture file and transferred it to a Samsung S8 (Android 9).

Took about 5 minutes.


Kindly check the version number installed on your camera. Toogle through the Menu then access the wrench icon (Settings) then access the gear icon then choose About.





Posts: 3,237

Re: Fusion + Pixel 3 Download Clip Issue

I've done an extensive write up on this problem when I encountered this issue

The short take away for me was that Firmware Version 2.0 on the Fusion won't work with app Ver 5.1.1. or  5.2.1.  You will try to download photo's or video, it will get halfway through the process before booting you to the "select your clip" section again.  However I could get it to work with Version 5.0 of the app.

I then downgraded my Fusion Firmware to 1.8 and it worked just fine with App Version 5.1.1 and 5.2.1.  I could then download and edit video again (although video seemed to edit a lot slower than before).


You may want to double check the firmware your camera is using and make sure it's running version 1.8 (2.0 was a beta version after all).  If it's running 1.8 and you're still having the issue the two suggestions I would try are either rolling back your app to version 5.0 or maybe trying to upgrade to Firmware 2.0 and see what happens.

Posts: 3,237

Re: Fusion + Pixel 3 Download Clip Issue

BTW.  GoPro Fusion Studio for Windows does support the creation of Overcapture video's.  It doesn't support active pan, zooms and tilts though.  For that you would need to use something like Adobe Premier Pro