Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Highlighted
Tourist
Posts: 3

Cannot connect Hero(2018) to App - Android10

I have a Samsung Galaxy S9.

I am unable to connect my app to my gopro. My gopro says connected but I get an error on my phone. I receive the error stating that the camea is set to 5.GHz but I need to change to 2.4GHz. I do not have wi-fi nad option under connections menu on my gopro

I have unistalled and re-installed app on my phone

I have dont factory reset on gopro

I have turned off autoconnect on wifi

I have turned wifi on and off

I switched to airplane mode and turned it off and tried all the steps to connect

 

I have read another post and tried all they stated but nothing works

 

Please help

Highlighted
Tourist
Posts: 5

Re: Cannot connect Hero(2018) to App - Android10

Exactly the same issue

 

Highlighted
GoPro
Posts: 11,571

Re: Cannot connect Hero(2018) to App - Android10

Hello, @sunnysand05563 and @cube218. If you haven't yet, we recommend doing a manual update of your cameras first. The steps under Manual Update here will guide you. 

 

Make sure that your camera is updated to the latest firmware, that your phone is updated to the latest OS version and that you have the latest version of the GoPro App installed as well. After the updates, restart your phone, clear cache (cache only, not data) on the app settings, and try pairing with the camera again. Connectivity should be working this time. 

 

If the issue persists, reset Wi-Fi connection by forgetting GoPro first from the list of Wi-Fi networks on your phone settings and deleting it from the list of Bluetooth devices. Also, remove the camera from the list on the GoPro App. Reset camera to factory settings, then re-pair.

 

Let us know how it works out. Thanks! 

Highlighted
Tourist
Posts: 5

Re: Cannot connect Hero(2018) to App - Android10

Still not pairing with my Samsung Android v9.0 Tried everthing to no avail.

Highlighted
GoPro
Posts: 14,133

Re: Cannot connect Hero(2018) to App - Android10

Hi @cube218

 

To help isolate the issue, try pairing the camera to a different phone.

If it's still the same, please reach out to our Support Team through https://gopro.com/help/ContactUs

 

Thanks!

Ej

Highlighted
Tourist
Posts: 3

Re: Cannot connect Hero(2018) to App - Android10

I followed the insructions to manually download the software. I put the card in my camera and nothing happened.  I only added the unzipped files (not the folder)

Highlighted
GoPro
Posts: 5,875

Re: Cannot connect Hero(2018) to App - Android10

@sunnysand05563, if in case the camera won’t initiate the update, it can be because the camera is not recognizing the update on the SD card. We do have some suggestions here that should help get the update working: 

  • Make sure the UPDATE folder is unzipped/extracted, before placing it on the SD card. If the folder is compressed, the camera will not be able to read it; 

  • Ensure the UPDATE folder does not have any additional characters in the folder title, i.e. "UPDATE (1)". The camera will only recognize a folder titled "UPDATE", in upper case letters with no additional characters; 

  • Format the SD card before placing the update folder/files onto the root of the card (format on your computer, or DELETE ALL files in the camera's Delete menu); (NOTE: Reformatting the SD card will delete all data off of the card, so be sure that you save any videos or pictures you want to keep on your computer before reformatting the SD card.)

  • Be sure to place the individual files within the UPDATE folder on the root level of the SD card.  

 

Once you have the necessary file(s) placed on the SD card, unplug it from the computer and insert the microSD card into your camera. Once it's plugged in, power on the camera. The update should automatically initiate.  

Highlighted
Tourist
Posts: 5

Re: Cannot connect Hero(2018) to App - Android9

Hi

Gopro H* updated to version 1.60, still unable to link to mobile app. I have literally tried everthing you have suggested including linking to anothe mobile without success. pretty annoyed at present. Even my Bluetooth option on the camera has disappeared.

 

Help!!