Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
Reply
Highlighted
Tourist
Posts: 4

Cannot Enable Preview - Camera will not connect via WiFi

I am trying to set my hero black 8 for the first time, and have been able to connect it to my phone via Bluetooth. It is detectable and I can control the camera. However, when I tap "Enable Preview", this will not connect. The camera tries to connect via WiFi, and the connection repeatedly fails.

 

I have followed the troubleshooting guide and have attempted the following:

 

- Changing the WiFi band.

- Removed the camera from the app history and repaired.

- Reset the WiFi on the GoPro.

- Deleted the camera from my phone's devices.

- I have turned off WiFi+

- I have followed the Huawei specific instructions on the troubleshooting guide.

 

None of the above solved the issue.

 

I am using the following:

 

Hero Black 8 (v1.6)

Huawei P10 Plus (Android 9)

GoPro app version 6.17

 

Is there any help that anyone can offer, please? Contact support just will not work on any device, after trying for days, and I am at the point of just wanting to return my camera...

Highlighted
Tourist
Posts: 4

Re: Cannot Enable Preview - Camera will not connect via WiFi

Same problem here....spent a couple of hours trying everything.....on the app on my android it looks like there is no wifi connection from my camera.......will give it another hour then im sending it back....i only got it yesterday.......

Highlighted
GoPro
Posts: 18,364

Re: Cannot Enable Preview - Camera will not connect via WiFi

Hi @timbom93

 

Thanks for trying to troubleshoot the issue.

To help isolate this further, please try pairing the camera with another phone.

 

@heroichike011

Please go over the steps on https://community.gopro.com/t5/en/Troubleshooting-GoPro-App-Connectivity-Issues/ta-p/392964

Can you also help us with the following information: Camera version, GoPro App version, phone and OS version.

 

Thanks!

Ej

 

Highlighted
Tourist
Posts: 4

Re: Cannot Enable Preview - Camera will not connect via WiFi

Hi Guys....

Tried the connectivty process twice with no look.....

I have a GoPro Hero 8 Black....purchased yesterday....actually last Sunday from US

arrived yesterday

Firmware is the latest downloaded from your site

Phone is a Samsung Galaxy S7

OS is Android....

The app operates everything as normal except there is no live view

on the top of the app screen in the camera tab mode it shows no Wifi connec tion...even though i can operate the camera

Regards from Terry

Highlighted
GoPro
Posts: 9,090

Re: Cannot Enable Preview - Camera will not connect via WiFi

Hello @heroichike011. Please make sure your mobile device, app, and camera are on their current versions. I also have a few troubleshooting suggestions that will help: 

  1. Restart your mobile device. 
  2. Once your phone is back on, turn on/off the Wi-Fi and Bluetooth. 
  3. Delete the GoPro camera under the Bluetooth and Wi-Fi entries in your mobile device’s settings. 
  4. Remove your camera entry from the GoPro App's history. 
    • Android: Open GoPro App. Press and hold the image of the camera and delete the entry from your camera history. 
    • iOS: Open GoPro App. Tap the pencil icon in the top-left corner of the Camera menu page. Tap the red X icon to delete the camera entry from your app’s history. 
  5. Clear the cache for the GoPro app in your device's settings under the "Applications" section. 
  6. Kill the app and relaunch it. 
  7. On your GoPro camera, turn the Wi-Fi off and on. Then restart the camera. 
  8. Now, put the camera in pairing mode. 
  9. Open the GoPro App on your phone and tap the camera icon. The app will try to connect via Bluetooth and take you through the pairing process. Follow the on-screen instructions in the app. 
    • Note: Some phones and regions require the camera to be in a 2.4GHz Wi-Fi band, you may also try this out. 
  10. For future reconnections, just make sure that the camera’s Wi-Fi is on and you’ll be all set. 

 

Let us know how it goes.

Highlighted
Tourist
Posts: 4

Re: Cannot Enable Preview - Camera will not connect via WiFi

Hi Guys.....followed your instructions to the letter with no better results.....

on my phone the gopro app is showing me the main control screen with the enable preview icon with a bar across it meaning not on........it doesnt matter what i do i cannot or have ever been able to get a picture on it........on the top of that screen from left to right is.....1...an arrow point left......2...a sd card symbol with 2h:33......3....a gps location symbol.........4.....a wifi fan symbol with a  a bar going through it....meaning no wifi.....but everything i have on my phone and on the gopro is saying its connected......

Getting pretty annoyed.....how do i send this back.....i have never put up with so much messing around on something as expensive as this.......its a shame because i took some great slomo shots yesterday at the lake.....regards from Terry

Highlighted
Tourist
Posts: 4

Re: Cannot Enable Preview - Camera will not connect via WiFi

Hi Guys.......OMG....just uninstalled everything and reinstalled everything while i was typing the last reply.....usually i leave everything on default whilst connecting to the camera....this time i had my camera on when i reinstalled the gopro app but this time i put my camera on 2.4Ghz from the start....usually i am on 5 when i connect and then change it.....this time i had it on 2.4 from the start and have now got a live view........2 days of my life wasted trying to sort this out.....was getting the packing box ready to post back......thanks for your help guys but that was hard work.....hope my experience helps others.......regards from Terry

Highlighted
Hiker
Posts: 120

Re: Cannot Enable Preview - Camera will not connect via WiFi

I had exactly the same problem the last days, but with a hero7 black.

 

I figured out 2 main issues...

 

The first, in my case was, that the more I have recorded the more tries it took until I got a remoteconnection by wifi (as well 5GHz).

So I wondered why bluetooth could connect immediately , and then wifi not ...

 

It was the amount of recorded clips/files on my SD-card. I had around 300 files on it, approx 125 clips , and maybe 200 *.jpg from timelapse.

Right after reformatting the card , I could connect without a poblem.....

Connecting to wifi seems to read the directory of all files stored inside the cam...... there seems to be some kind of android running.

 

BUT..

 

the second issue is as well reproducable.

If connecting to different devices like ...the app ...and ... the smart remote... there is no connection possible anymore from the second change on.

You have to reset all connections on the hero itself, and pair your devices again.......

 

what a buggy software !

 

is there anything at gopro , that works stable ?

 

maybe these hints can help someone else....