Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Mobile
%3CLINGO-SUB%20id%3D%22lingo-sub-413866%22%20slang%3D%22en-US%22%3EBug%3A%20Using%20keyframes%20and%20playback%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-413866%22%20slang%3D%22en-US%22%3E%3CP%3EI%20found%20a%20little%20bug%20on%20my%20device.%26nbsp%3B%20I%20haven't%20tried%20it%20on%20other%20iOS%20devices%2C%20but%20here's%20it%20is....%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20add%20keyframes%20to%20my%20360%20footage%20with%20no%20issues.%26nbsp%3B%20After%20I%20do%20some%20edits%2C%20I%20tap%20%22Save%22%20-%26gt%3B%20%22Save%20Draft%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20go%20back%20to%20edit%20the%20keyframes%2C%20my%20previous%20keyframes%20show%20up%20nicely%2C%20but%20here's%20the%20bug...%26nbsp%3B%20everytime%20the%20video%20is%20paused%20while%20I%20add%20%2F%20edit%26nbsp%3B%20%2F%20delete%20keyframes%20or%20scrub%20through%20the%20timeline%2C%20and%20then%20I%20tap%20Play%2C%20the%20video%20goes%20back%20to%20the%20beginning%20of%20the%20video%20instead%20of%20continuing%20where%20the%20playhead%20is.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOnly%20when%20I%20%22Clear%20All%20Keyframes%22%2C%20then%20things%20work%20as%20normal%2C%20but%20this%20means%20that%20my%20previous%20work%20as%20been%20cleared.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20too%20big%20of%20a%20deal%20because%20I%20usually%20only%20edit%20small%20clips%20at%20a%20time%20anyway.%26nbsp%3B%20I%20haven't%20had%20this%20issue%20on%20my%20Android%20phone.%26nbsp%3B%20I%20will%20test%20out%20on%20other%20iOS%20devices.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20are%20all%20the%20specs...%3C%2FP%3E%3CP%3EGoPro%20app%20Version%206.2%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3EiPad%209.7%202018%2C%26nbsp%3B%20iOS%2013.1.2%3C%2FP%3E%3CP%3EGoPro%20Fusion%20footage.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-413866%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EGoPro%20App%20for%20iOS%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-413919%22%20slang%3D%22en-US%22%3ERe%3A%20Bug%3A%20Using%20keyframes%20and%20playback%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-413919%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%20for%20the%20feedback%2C%20%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F124954%22%20target%3D%22_blank%22%3E%40patrickc0060%3C%2FA%3E.%20We%20appreciate%20you%20providing%20details%20on%20the%20issue.%20We%20will%20pass%20this%20on%20to%20the%20team%20for%20a%20closer%20look.%20While%20you%20do%20further%20test%2C%20see%20if%20updating%20your%20device%20to%20the%20latest%20OS%2C%2013.1.3%2C%20will%20make%20a%20difference.%20We%20hope%20to%20hear%20back%20from%20you.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-413985%22%20slang%3D%22en-US%22%3ERe%3A%20Bug%3A%20Using%20keyframes%20and%20playback%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-413985%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F56774%22%20target%3D%22_blank%22%3E%40mariustanya%3C%2FA%3E%26nbsp%3BThanks%20for%20the%20feedback.%26nbsp%3B%20Just%20updated%20and%20it%20did%20the%20same%20thing.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-414122%22%20slang%3D%22en-US%22%3ERe%3A%20Bug%3A%20Using%20keyframes%20and%20playback%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-414122%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F124954%22%20target%3D%22_blank%22%3E%40patrickc0060%3C%2FA%3E%2C%20thanks%20for%20posting%20back%20with%20an%20update.%20I'll%20share%20the%20details%20with%20the%20team%20in%20charge.%20We'll%20keep%20you%20posted%20with%20any%20new%20information%20that%20we%20get.%20Your%20patience%20and%20understanding%20are%20very%20much%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-416272%22%20slang%3D%22en-US%22%3ERe%3A%20Bug%3A%20Using%20keyframes%20and%20playback%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-416272%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F124954%22%20target%3D%22_blank%22%3E%40patrickc0060%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F35373%22%20target%3D%22_blank%22%3E%40aenriquez%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F56774%22%20target%3D%22_blank%22%3E%40mariustanya%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EThanks%20for%20the%20bug%20report.%3CBR%20%2F%3EI%20have%20followed%20your%20steps%20and%20I%20was%20not%20able%20to%20reproduce%20the%20bug%20-%20I%20am%20running%20version%206.2.2%20which%20is%20an%20update%20coming%20up%20next.%3CBR%20%2F%3EThere%20will%20be%20a%206.2.1%20soon%20and%20a%206.2.2%20as%20well%20-%20all%20coming%20with%20many%20bug%20fixes.%3CBR%20%2F%3EHope%20you%20can%20be%20patient%2C%20we're%20on%20it%20%3A)%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Highlighted
Sightseer
Posts: 2
Accepted Solution

Bug: Using keyframes and playback

I found a little bug on my device.  I haven't tried it on other iOS devices, but here's it is....

 

I can add keyframes to my 360 footage with no issues.  After I do some edits, I tap "Save" -> "Save Draft"

 

When I go back to edit the keyframes, my previous keyframes show up nicely, but here's the bug...  everytime the video is paused while I add / edit  / delete keyframes or scrub through the timeline, and then I tap Play, the video goes back to the beginning of the video instead of continuing where the playhead is.

 

Only when I "Clear All Keyframes", then things work as normal, but this means that my previous work as been cleared.  

 

Not too big of a deal because I usually only edit small clips at a time anyway.  I haven't had this issue on my Android phone.  I will test out on other iOS devices.  

 

Here are all the specs...

GoPro app Version 6.2  

iPad 9.7 2018,  iOS 13.1.2

GoPro Fusion footage.  


Accepted Solutions
GoPro
Posts: 660

Re: Bug: Using keyframes and playback

@patrickc0060 @aenriquez @mariustanya 
Thanks for the bug report.
I have followed your steps and I was not able to reproduce the bug - I am running version 6.2.2 which is an update coming up next.
There will be a 6.2.1 soon and a 6.2.2 as well - all coming with many bug fixes.
Hope you can be patient, we're on it :) 

View solution in original post


All Replies
GoPro
Posts: 8,294

Re: Bug: Using keyframes and playback

Thank you for the feedback, @patrickc0060. We appreciate you providing details on the issue. We will pass this on to the team for a closer look. While you do further test, see if updating your device to the latest OS, 13.1.3, will make a difference. We hope to hear back from you. 

Sightseer
Posts: 2

Re: Bug: Using keyframes and playback

@mariustanya Thanks for the feedback.  Just updated and it did the same thing.  

GoPro
Posts: 3,193

Re: Bug: Using keyframes and playback

@patrickc0060, thanks for posting back with an update. I'll share the details with the team in charge. We'll keep you posted with any new information that we get. Your patience and understanding are very much appreciated.

GoPro
Posts: 660

Re: Bug: Using keyframes and playback

@patrickc0060 @aenriquez @mariustanya 
Thanks for the bug report.
I have followed your steps and I was not able to reproduce the bug - I am running version 6.2.2 which is an update coming up next.
There will be a 6.2.1 soon and a 6.2.2 as well - all coming with many bug fixes.
Hope you can be patient, we're on it :)