Ask a Question
GoPro Support Hub Find a solution. Share a solution. Ask a question. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
%3CLINGO-SUB%20id%3D%22lingo-sub-332005%22%20slang%3D%22en-US%22%3Eunable%20to%20download%20quicl%20app%2C%20states%20programs%20requires%20a%20newer%20version%20of%20windows%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-332005%22%20slang%3D%22en-US%22%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-332005%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EQuik%20for%20Desktop%20-%20Windows%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-332014%22%20slang%3D%22en-US%22%3ERe%3A%20unable%20to%20download%20quicl%20app%2C%20states%20programs%20requires%20a%20newer%20version%20of%20windows%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-332014%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F99139%22%20target%3D%22_blank%22%3E%40bolddawn51455%3C%2FA%3E%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EPlease%20refer%20to%20this%20%3CA%20href%3D%22https%3A%2F%2Fgopro.com%2Fhelp%2Farticles%2Fquestion_answer%2FWhat-are-the-Minimum-System-Requirements-for-GoPro-App-for-Desktop%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Elink%20%3C%2FA%3Efor%20the%20app's%20minimum%20system%20requirements%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EThanks!%3C%2FP%3E%0A%0A%3CP%3EEj%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Sightseer
Posts: 1
Accepted Solution

unable to download quicl app, states programs requires a newer version of windows

 

Accepted Solutions
GoPro
Posts: 7,699

Re: unable to download quicl app, states programs requires a newer version of windows

Hi @bolddawn51455

 

Please refer to this link for the app's minimum system requirements

 

Thanks!

Ej

View solution in original post


All Replies
GoPro
Posts: 7,699

Re: unable to download quicl app, states programs requires a newer version of windows

Hi @bolddawn51455

 

Please refer to this link for the app's minimum system requirements

 

Thanks!

Ej