Ask a Question
GoPro Support Hub Find a solution. Share a solution. Ask a question. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 13

Re: gopro fusion studio 1.3 uses 16gb memory then crashes



software still broken.


new users researchinng this camera for christmas, DO NOT BUY IT, the software is broken at best.  

Posts: 4

Re: gopro fusion studio 1.3 uses 16gb memory then crashes

I'm having a similar problem. I don't think it crashes at exactly 16GB for me.


I'm running Mac OS 10.14 (Mojave) and Fusion Studio 1.3, and my Fusion is on 1.8, whatever the latest is. (I have 16 GB 1600 MHz DDR3 RAM, on a MacBook Pro Retina, 13-inch, Mid 2014.


I tried rendering some relatively short clips at 5K because I intended to edit it in Premiere Pro 2019 afterward. After an hour or so of almost no progress Fusion Studio crashed. I decreased the reder settings to 4K and H.264 and had better luck. After several hours a few clips rendered, then Fusion Studio crashed again.


Each of the successfully rendered clips is less than one minute long... and took nearly an hour each.


Am I better off stitching and rendering in some other software? Is that even possible?


Is it possible to use some kind of cloud render service like Zync or Pixel Plow instead of my own machine?


Finally, because my Mac couldn't connect to the Fusion, the only way I could read and stitch was by having both SD cards on card readers connected at once. I have one micro-SD to USB adapter and used one of the micro to SD adapter. Perhaps it's faster to render only directly from the camera? (I have managed to connect it just now.)

Posts: 14

Re: gopro fusion studio 1.3 uses 16gb memory then crashes

There are several things to try. First thing is to transfer the SD card contents to a folder on your computer. Go into the sd files system down to the video/photo raw files and transfer all those across. Do it for both sd cards into the same folder. Select add media in the Studio program. Then select the Edit button at the top and select preferences and choose the folder you want the rendered output to go. I use the same folder as the video/photos. Now you will see the video/photos to render. Select one for now. When you go to the render page you have choices for the codecs and I find the far right one works for me. Also Stereo instead of surround works. If you still have problems try a different render codec choice. When you get it working there is lots to find out about the way to shoot and render which also depends on whether you are viewing the output on a screen or goggles. See for example. If all else fails download Fusion Studio 1.1  which seemed to work for most people. I have just gone to 1.4 and updated firmware and it works if I select the modes above (which also worked in 1,3 )

A look at the problem of shooting a spiral staircase decent in 360 VR. This shows the problems of a rotating shoot with a 360 camera in this case a GoPro Fusion and the different ways to process the video. Motion sickness can be caused by 360 VR and the processing or render/sdit differences can ...
Posts: 7,104

Re: gopro fusion studio 1.3 uses 16gb memory then crashes

Hello @erinf307. See how it goes after you update to the latest Fusion firmware and Fusion Studio version. The Beta updates were released last January 16 and details can be found here . Let us know how it works out. 

Posts: 4

Re: gopro fusion studio 1.3 uses 16gb memory then crashes

Thanks so much, @mariustanya! Would I have to re-shoot my footage to get the beta to work?


Just checking!


Posts: 2

Re: gopro fusion studio 1.3 uses 16gb memory then crashes

Hi All,


I've come across a few of these threads while trying to understand my Fusion Studio issues.


Seems I'm sufferieng from the same problem.


Stiching 5mins of 3K 60fps footage to H264 with 360 audio results in 32GB of RAM (all of it) being used and 60+GB of swap.


Given all the resources it wants though the renders do eventially complete.


Rendering the same videos with stereo sound (and no other settings changed) works well with RAM usage no higher than 17GB with no swap used. As mentioned in this post:


I've tried both Studio 1.3 and the newly released 1.4 beta. Both exhibit the same symptoms, so the problem doesn't appear to be fixed.


The footage I'm working with was however shot with the older firmware.


Another thread mentioned pausing the rendering process. Strangely it seems this has an effect, if paused for 30s or so every 10% the memory usage can be seen dropping while paused back to a normal 3-5GB from 15-20GB.


For now that seems to be an acceptable workaround, however it makes for clearing the render queue overnight a little difficult :-(.

Posts: 7,606

Re: gopro fusion studio 1.3 uses 16gb memory then crashes

Thanks for getting back to us @toughshore70427


Are you importing from the camera or are the files already stored to your local drive?

Do you still remember the render options you have used?


Kindly try these combinations and let us know how it goes.

If you choose Pro-Res, use 360 audio.

For CineForm. select Stereo.


Let us know this goes.




Posts: 2

Re: gopro fusion studio 1.3 uses 16gb memory then crashes

Hey @aragon1006 ,


Thanks for getting back to me.


The settings I've used were:


Stabilization: Anti-shake

H.264 @ 3K (due to capturing at 60fps).

360 audio.

D Warp on


I've been rendering from my hard drive. I don't take a very powerful machine on my travels. Instead I've been offloading the memory cards for rendering later.


So far I've been using Fusion studio as the sole authoring tool for the content coming off the camera (as a suppliment to my normal GoPro footage), hence selecting H264 to publish directly.


As you requested I tried a few different combinations, with Fusion Studio 1.4, re-rendering one of my previous clips, with a duration of approx 5mins.


ProRes 3K with 360 audio: no unexpected memory usage or issues with fusion studio using around 1.1GB.


Cineform 3K with stereo audio: again no issues, with memory usage around 1.2GB.


An additional few:


H.264 3K with stereo audio: memory usage climbed to over 10GB before stitching reached 10%. I wasn't able to let it finish (as I needed my RAM for other work :-P)


In which case it seems that the issue I've been experiencing goes slightly further than 360 degree audio, potentially involving H.264 rendering in general.


I was going to say I havent experienced this before, however I've only just purchased the camera. So far rendering has been limited to a few 30 sec clips to get used to the workflow. Having got back from my holiday I've just tried to stich a load of footage.


Other than that I've found Fusion Studio to be pretty stable and usable. While the workaround for now is strangely just pausing it every 10% or so, after which the memory usage starts to drop it would be good to see a proper fix.


If it helps I can supply the raw footage I'm stitching, let me know!