Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 4

Solution for Quik app "Not Responding" in Windows 10

[ New ]

For those of you struggling with GoPro Quik "not responding" and/or crashing on your Windows 10 devices, here is a solution that worked flawlessly for me on two machines (laptop and desktop):


I'll take this step-by-step:


  • Locate your desktop shortcut (or program shortcut) for GoPro Quik
  • Right-click on the shortcut and select "Run with graphics processor" - then left-click on "Integrated graphics (default)"
    • Here's a screenshot:
    • gp-snap1.jpg
  • When Quik opens, navigate to Media then attempt to open a file - standard video should be the first thing you try.
  • If this works, continue with the steps below to make Quik open this way by default in future loads.  If this does not work, you can stop here as my solution will not help you.


I spoke with Tech Support, and they emailed me the following steps to set Quik to open using the Integrated Graphics by default.  Here is the exact email - since most of us having this problem are using either AMD or NVidia graphics cards, this is what they sent.  Note that it mentions "Studio" in the instructions - but this worked for Quik:



Step One:
Open the Nvidia Control Panel. You can do this by right-clicking on the desktop or you can find the option within the notification area of the Taskbar.

Step Two:
Select Manage 3D Settings under 3D Settings

Step Three:
Click on the Program Settings tab and select the program you want to choose a graphics card for from the drop down list. In Program Settings, click the ADD button and browse the following location to select the GoPro Studio.exe application: "c:\program files (x86)\gopro\tools\"

SIDE NOTE:  For this I simply selected "GoPro Quik.exe" from the recentely used programs.  Here's a snapshot:



Step Four:
Now select the 'preferred graphics processor' in the drop down list (you can see what the automatic option is listed as global setting). If you want to use the dedicated graphics card, select High-performance Nvidia processor. (SIDE NOTE: Nvidia did not work for me - it hung when I tried it)


Click "Apply".

Note: For ATI/AMD graphics cards the process varies. Open the control center in the same way as above. You may need to open graphics then PowerPlay and set plugged in and/or battery to maximize performance. You can also try going to graphics then 3D and move the slider to performance. Your computer may also have a switchable graphics tab where you can change the settings for individual programs.

This will ensure that the dedicated card is selected, and you get the best performance from GoPro Studio.

Here is a Video showing how to do this process:



Lastly - here's a video I made to show that it works:


Hope this helps others who have been struggling with this!

Hey guys, this is a tutorial on how to switch between your AMD graphics card and your intel HD 4000 integrated graphics. This is also a comparison video betw...