Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 19

Quik on Windows 10 Has Stopped Working

[ New ]

Everything has been great with the Quik Desktop program... until today.

Double clicking the icon no longer starts the program, or it starts, but crashes before it shows the media list.

I've uninstalled, deleted the GoPro folder from Application Data, reinstalled, run in Vista SP2 Compatability mode and repeated these steps several times.

Is just won't work anymore!

The only change is an update of my nVidia GPU drivers to the latest WHQL version.

And everything else works fine.

I only use Quik to copy videos from my HERO 8 Black to my PC and then delete them - it's a few clicks and really convinient, so I'd like to get it working again if this is something that's a known issue with a fix.

Posts: 20,766

Re: Quik on Windows 10 Has Stopped Working

[ New ]

Hello, @fuzzuk. You may have already tried some of these troubleshooting steps but check out the other recommendations. You may also uninstall and re-install the app. 


If none of the above works, our Support team at will be able to help you with further steps. Be sure that you have access to your camera and your computer when you get in touch with them. Thanks!

Posts: 19

Re: Quik on Windows 10 Has Stopped Working

[ New ]

I've completely rremoved and then reinstalled it several times...

At the end of the installer, it tries to automatically run it, but nothing happens.

If I then choose compat mode for Vista SP2 then the program will run ONCE. 

If I exit and try and run it again it bombs...


Faulting application name: GoPro Quik.exe, version:, time stamp: 0x5b897c2a
Faulting module name: Qt5WebEngineCore.dll, version:, time stamp: 0x56d89c3b
Exception code: 0x80000003
Fault offset: 0x00000000009acbc8
Faulting process ID: 0x460
Faulting application start time: 0x01d60b5f86639a3f
Faulting application path: C:\Program Files\GoPro\GoPro Desktop App\GoPro Quik.exe
Faulting module path: C:\Program Files\GoPro\GoPro Desktop App\Qt5WebEngineCore.dll
Report ID: 2c5f0400-858b-4c62-93ea-fe791d2688d4
Faulting package full name:
Faulting package-relative application ID:

It's really irritasitng becasue it's been working *perfectly* for years - and not just with my HERO 8, it's been fine since I got my original HERO 6 years ago!

Posts: 19

Re: Quik on Windows 10 Has Stopped Working

[ New ]

Here's an update just in case people get the same issue...

I gave up and removed Quik completely - unistalled it and then deleted all the left over folders and associated files.

Essentially these folders...

C:\Program Files\GoPro


I then rebooted and ran CCleaner to check for and remove any leftover registry entries.

Then I just got on with my life for a week or so... used my PC, did a few updates, used my GoPro and copied the files from it manually using a USB cable.

Then I just thought I'd try Quik again.... so I reinstalled using the latest version - the same one I had tried to use before - and guess what?

It's working.

I pointed towards the previous location for the camera import, clicked 'rescan' and it's all fine.

One click importing and camera card deletion is back.

No idea why it broke and no idea why its working again.