Ask a Question
GoPro Support Hub Find a solution. Share a solution. Ask a question. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
%3CLINGO-SUB%20id%3D%22lingo-sub-23259%22%20slang%3D%22en-US%22%3EQuik-MacInstaller-2.1.0.5334%20-%20Quik%20will%20not%20run%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-23259%22%20slang%3D%22en-US%22%3E%3CP%3ELatest%20version%20of%20OSX%20Quik%20downloaded%20and%20installed%20OK.%20%26nbsp%3BGoPro%20Studio%20runs%20OK%2C%20but%20Quik%20will%20not%20run.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUnistalled%20both%2C%20restarted%20and%20reinstalled%2C%20but%20same%20result.%20%26nbsp%3BPrevious%20version%20was%20working%20OK.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EProcess%3A%20Quik%20%5B1454%5D%3CBR%20%2F%3EPath%3A%20%2FApplications%2FQuik.app%2FContents%2FMacOS%2FQuik%3CBR%20%2F%3EIdentifier%3A%20com.GoPro.goproapp%3CBR%20%2F%3EVersion%3A%202.1.0%20(2.1.0.5334)%3CBR%20%2F%3ECode%20Type%3A%20X86-64%20(Native)%3CBR%20%2F%3EParent%20Process%3A%20%3F%3F%3F%20%5B1%5D%3CBR%20%2F%3EResponsible%3A%20Quik%20%5B1454%5D%3CBR%20%2F%3EUser%20ID%3A%20501%3C%2FP%3E%3CP%3EDate%2FTime%3A%202016-12-02%2017%3A07%3A55.386%20%2B0000%3CBR%20%2F%3EOS%20Version%3A%20Mac%20OS%20X%2010.12.1%20(16B2555)%3CBR%20%2F%3EReport%20Version%3A%2012%3CBR%20%2F%3EAnonymous%20UUID%3A%20480535E8-D644-7113-1DB7-04DF3BD221C9%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETime%20Awake%20Since%20Boot%3A%201100%20seconds%3C%2FP%3E%3CP%3ESystem%20Integrity%20Protection%3A%20enabled%3C%2FP%3E%3CP%3ECrashed%20Thread%3A%200%20Dispatch%20queue%3A%20com.apple.main-thread%3C%2FP%3E%3CP%3EException%20Type%3A%20EXC_CRASH%20(SIGABRT)%3CBR%20%2F%3EException%20Codes%3A%200x0000000000000000%2C%200x0000000000000000%3CBR%20%2F%3EException%20Note%3A%20EXC_CORPSE_NOTIFY%3C%2FP%3E%3CP%3EApplication%20Specific%20Information%3A%3CBR%20%2F%3E***%20Terminating%20app%20due%20to%20uncaught%20exception%20'NSInvalidArgumentException'%2C%20reason%3A%20'***%20-%5BNSFileManager%20contentsOfDirectoryAtURL%3AincludingPropertiesForKeys%3Aoptions%3Aerror%3A%5D%3A%20URL%20is%20nil'%3CBR%20%2F%3Eabort()%20called%3CBR%20%2F%3Eterminating%20with%20uncaught%20exception%20of%20type%20NSException%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-23259%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EQuik%20for%20Desktop%20-%20Mac%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-23262%22%20slang%3D%22en-US%22%3ERe%3A%20Quik-MacInstaller-2.1.0.5334%20-%20Quik%20will%20not%20run%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-23262%22%20slang%3D%22en-US%22%3E%3CP%3EQuik%20V%202.0.1.5076%20recovered%20using%20Time%20Machine%20and%20runs%20without%20any%20problem%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Hiker
Posts: 124

Quik-MacInstaller-2.1.0.5334 - Quik will not run

Latest version of OSX Quik downloaded and installed OK.  GoPro Studio runs OK, but Quik will not run. 

 

Unistalled both, restarted and reinstalled, but same result.  Previous version was working OK.

 

Process: Quik [1454]
Path: /Applications/Quik.app/Contents/MacOS/Quik
Identifier: com.GoPro.goproapp
Version: 2.1.0 (2.1.0.5334)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Quik [1454]
User ID: 501

Date/Time: 2016-12-02 17:07:55.386 +0000
OS Version: Mac OS X 10.12.1 (16B2555)
Report Version: 12
Anonymous UUID: 480535E8-D644-7113-1DB7-04DF3BD221C9

 

Time Awake Since Boot: 1100 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSFileManager contentsOfDirectoryAtURL:includingPropertiesForKeys:options:error:]: URL is nil'
abort() called
terminating with uncaught exception of type NSException

Hiker
Posts: 124

Re: Quik-MacInstaller-2.1.0.5334 - Quik will not run

Quik V 2.0.1.5076 recovered using Time Machine and runs without any problem

Sightseer
Posts: 1

Re: Quik-MacInstaller-2.1.0.5334 - Quik will not run

I was having the same problem. I was just upgrading from the gopro app (the old one) and it kept crashing. I installed the older version of Quik and it runs good now. Still haven't tried the newest one again

Hiker
Posts: 124

Re: Quik-MacInstaller-2.1.0.5334 - Quik will not run

There doesn't seem to be much input for the GoPro support team here - maybe they are all on holiday?

 

Waiting - with many others I suspect - for the Karma Grip to be re-released.

Hiker
Posts: 124

Re: Quik-MacInstaller-2.1.0.5334 - Quik will not run

[ Edited ]

Quick v2.1 installed on my 2011 MacBook Air and it runs OK.

 

Reinstalled on my 2010 iMac and still won't run.  It starts to run, showing in the dock as a bouncing icon, then that diasappears and I get the 'Quik quit unexpectedly' window.

 

v2.0.1 runs without any issues.

Capto_Capture 2016-12-05_04-29-51_pm.png
GoPro Community Manager
Posts: 5,837

Re: Quik-MacInstaller-2.1.0.5334 - Quik will not run

@ruyton - The best way to reach a GoPro Support team member is to contact us directly at https://gopro.com/help/PKBContactus. The GoPro Support Hub is designed to be a customer to customer support channel. Employees help out where we can, but we are not able to address every post that is made on these boards.

 

Thanks,

Jeff

Hiker
Posts: 124

Re: Quik-MacInstaller-2.1.0.5334 - Quik will not run

My misunderstanding then Jeff - GoPro website and GoPro Support Hub - assumed this was the 'official' support.

 

I'll contact GoPro direct as you suggest.

 

Thanks

Hiker
Posts: 124

Re: Quik-MacInstaller-2.1.0.5334 - Quik will not run

I've had a reply form GoPro support via email and they are helping to sort out my problem.

 

Thier first advice was to create a new Admin account on my iMac and to try running Quik v2.1.0 again - and yes, it did run, so it must be something to do with my main account.