Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 5

QUIK snapshot problem

[ New ]

Cam: Gopro Hero 5

PC specs: amd ryzen 5 1600

                 amd rx580 4gb

                 16 gb ram


quik for windows 2.6.2841


i can't take a screenshot  from any video i capture. the only thing i get is the **bleep** spinning cycle and the message "SAVING TO EDITS"

Any thoughts?



PS. Gopro staff, please don't tell me to contact your "support" team. i tried several times and i got no answer. we all know that your aftermarket support is ridiculous

Posts: 6,097

Re: QUIK snapshot problem

[ New ]


Sorry to know that. @aris11



Have you tried reinstalling the software? 

Try to run it on compatibility mode by right clicking on the app icon and choose run in compatibility mode. 

Other option will be run with graphics processor. 


Please let us know if that will work. 


Best Regards,


Posts: 5

Re: QUIK snapshot problem

[ New ]
Of course i tried both. Please give a real solution. And yes, my pc was plugged in the socket.
First gen Ryzen processors don't have intergrated graphics, as everybody knows. You know, you need a separate gpu to have things on the screen.

PS. This is my third problem which your "support" could not solve. I paid 430 euros for random-chinese-camera support. Great.
Posts: 19,761

Re: QUIK snapshot problem

[ New ]

Hello @aris11


Sorry about the trouble. I could not be certain if this is particular to computer settings, but I just tried to photo grab on my end and I was able to do so successfully. I am using a Windows 10 computer with Quik for desktop version

Our team is aware of this issue and is working towards a resolution. We have yet to hear from them for an update. We will keep you posted. 


Best regards,