Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 1

GoPro Quik import/delete not reliable

Hi everyone.

Recently got my first GoPro (Hero5Black) and installed Quik on my Macbook Pro.
I usually connect my microSD to my computer through a card reader adaptor to access my footage. Using the 'usb-c to usb' cable to connect directly to the camera never works for me. This is a separate issue, but maybe someone can tell me if that's also normal.

Anyway, when using the import files button, Quik usually imports my .mp4s no problem. However, every time I press delete files after a successful import, it never seems to fully work. Sometimes it deletes the files off the card, sometimes not, but every time the red deletion progress bar under my connected HERO5 BLACK stops at like 95% and stays there indefinitely. Meanwhile the SD card (32GB) capacity gauge always shows around 30-35% used, even when I verify that the card is empty through finder. Also, sometimes 'import files' just fails to import all my files for some reason. All this makes me very nervous about using Quik, I always have to look through the card manually to make sure all my clips are imported before deleting. 

Anyone else experiencing similar unreliability? Really turns me off of using Quik altogether as a safe and fast way of importing footage.

GoPro Community Manager
Posts: 5,861

Re: GoPro Quik import/delete not reliable

@greensurf14683 - For the USB-C to USB connection, one hangup that seems to stop a lot of people from getting that to work is to make sure that the camera is turned on after it's connected to the computer. Many people have the camera turned off, which puts the camera into a charging mode. Turning the camera on will move it into a pairing mode.


Import errors can often be linked to corrupt of non-GoPro files on the SD card. Quik won't import those. If you really want to clear the SD card after an import, pop the SD card back into the camera and reformat the card. That will clear everything off.




Posts: 1

Re: GoPro Quik import/delete not reliable

[ Edited ]

Is there still no fix to this issue because it's really troublesome and seems like it should be simple.  I always turn the camera on before connecting the USB and there are no other non GoPro files on the SD card.


Depending on the day or something I get different messages like this one on the attached photo. On the left is says "Initializing Delete" and in the middle it says "Delete Complete".  But when I look at the media on the camera itself, everthing is still there.



Screen Shot 2018-01-31 at 9.04.14 PM.png
Posts: 5

Re: GoPro Quik import/delete not reliable

Same problems here with a gopro 6 and macbook pro.

At the moment my sdcard is empty and it still says its 25% used.

Often it says it deletes the files, but in practice it doesn't. Feels very unreliable.

Posts: 2

Re: GoPro Quik import/delete not reliable

Same here. I currently have a GoPro HERO5 Session, but it was doing the same thing with a GoPro HERO4 Session. GoPro really needs to fix this.

Posts: 2

Re: GoPro Quik import/delete not reliable

I see the same behavior using Quik with my Hero4 Silver on a Mac Book Pro 2017 (High Sierra) with a USB-C-to-USB adapter. It does seem to transfer and delete recently captured media from the camera, but there are ~300 older files still on the camera's card that it either cannot transfer or cannot delete. I see the "Initializing delete" message on Quik indefinitely.


Using a card reader adapter has been more reliable, but is much less convenient because the micro SD card is difficult to manipulate, and I worry about losing or damaging it.

Posts: 8,211

Re: GoPro Quik import/delete not reliable

Hello @spiryrange08603


Thank you for sharing. I am gathering that you have the "Automatically delete files after importing" feature on on your Quik for desktop app. It is odd though that Quik does not recognize or automatically deletes all the files on the SD card. Have you already downloaded the latest version of Quik for desktop (v2.6.1)? Also, are you using a recommended SD card for your camera? See the list here. If you have already saved all the media that you need, you can try updating Quik and formatting your SD card to start over. The remaining files on your SD card might be eating up memory space on your SD card that could be used for newer footage. Let us know if you still get the initializing message after the update. 


Best regards, 

Posts: 2

Re: GoPro Quik import/delete not reliable

Hi @mariustanya,


Thanks for the quick response. I updated my Quick desktop app and formatted the SD card, since all media had been imported, just not deleted. After formatting the SD card, videos are automatically deleted after import, but photos are NOT deleted. I have to manually delete the photos or perform another SD card re-formatting to clear them off the camera.


After reformatting of the SD card, Quik does not display the "Initializing delete" message after importing, but it did re-appear once in my testing when I performed a subsequent import of new images/videos recorded since the previous import without manually deleting the photos that were not auto-deleted during import. Got that?



Some follow-ups & questions:

  • I'm using a compatible SD card (SanDisk Extreme PLUS UHS-I 64GB).
  • Do you recommend re-formatting the SD card on a regular basis?
  • Should the camera be turned ON or OFF when connected to my laptop for importing media?
  • Perhaps the USB-C-to-USB adapter is causing trouble. Do you provide a direct connector cable for USB-C ports?
  • Quik desktop app version: I was using v2.6.0.666 but have upgraded to the latest version (v2.6.1.713).
    • I have the "automatically download updates" setting turned on, but I didn't get a notice about the update until I quit and restarted the app.
  • Where is the Quik's option for "Automatically delete files after importing"? I don't see it in the general settings for the desktop app or when importing.
  • Unrelated: Under what conditions is the "View > Enter Fullscreen" menu item enabled in the Quik app? It seems to be always disabled in both view and create modes.

Thanks for you help!