Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 1

GoPro Quik App not loading on Windows10 account

[ New ]

Hello! I have tried all the workarounds I could find and am still unable to open the Quik app on my Dell laptop (Windows 10). I did check the compatibility mode which did not help. I then created a separate admin account in which the app opened perfectly and then tried deleting the goproapp.json from my original admin account, but still cannot get it to open on my original admin account. I get a pop-up asking me if I want to allow the app to make changes to my device and I click yes. Then it shows the thumbnail of the app on my taskbar but the app window itself is not showing up. Any additional ideas on how to fix this? The quik app is version 2.7.0

Posts: 11,085

Re: GoPro Quik App not loading on Windows10 account

[ New ]

@jamesb8642, you may also try the following steps in addition to the suggestions above: 

  1. Close Quik for desktop 
  2. Open Windows Explorer by pressing Windows key + E 
  3. Click the View tab at the top of this window and make sure the box next to "Show hidden files" is checked 
  4. Navigate to C:\Users\<Your Username>\AppData\Local and delete the "GoPro" folder 
  5. Restart Quik for desktop and see if the issue persists 


If the issue persists after going through the suggested troubleshooting steps, our Support team will be able to assist you further in resolving this. You may reach out to them through to initiate a callback request or chat with one of the representatives.