Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 1

GPS not working with Quik desktop

Just got a Hero7 Black. GPS guages work great in the app but not in Quik. I've seen in other threads that downloading an older verion of Quik solves the issues but is there a fix for the latest version yet?

Posts: 3,184

Re: GPS not working with Quik desktop

Hi @jeremym820,

This issue has already been shared to the team in charge. We’ll do our best to keep everyone posted as soon as we have any further update. In the meantime, you may use Quik for Mobile or should you need to use a desktop app, many users suggest Racerender or Dashware.

Kind Regards,


Posts: 1

Re: GPS not working with Quik desktop

[ Edited ]

It really worked here, but after some seconds the "GPS sign was not found" came back. But at least, I've got the map. I will test this method over the week inside buildings and phone is Zenfone 4. I used to have the Zoom 3 and PokGo worked really well, but now I'm having this problem frequently.