Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
%3CLINGO-SUB%20id%3D%22lingo-sub-4932%22%20slang%3D%22en-US%22%3EError%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-4932%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20there%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20creating%20a%20movie%20and%20exporting%20my%20progress%20evey%20now%20and%20then.%20A%20couple%20of%20times%20I've%20succesfully%20exported%20using%20the%20HD%201080p%20option%20to%20.mp4.%20Now%20however%2C%20I'm%20having%20issues%20exporting%20the%20same%20movie.%20I've%20made%20some%20progress%2C%20the%20movie%20now%20lasts%2011%20minutes%20instead%20of%206.%20No%20big%20deal%2C%20you%20would%20think.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20exporting%20I%20get%20the%20error%20%22error%20preparing%20ExporterEncoderFileWriter%22.%20Only%20when%20exporting%20to%20avi%20(much%20bigger%20files%20%3A(%20)%20i%20can%20get%20a%20result.%20It's%20really%20weird%2C%20because%20it%20is%20the%20exact%20same%20movie%20that%20could%20be%20exported%20to%20.mp4%20a%20few%20days%20ago%2C%20but%20now%2C%20won't.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20the%20following%3C%2FP%3E%3CP%3E-%20searching%20for%20the%20issue%20on%20this%20forum%3A%20no%20results%3C%2FP%3E%3CP%3E-%20googling%20the%20error.%20I%20found%20some%20small%20threads%2C%20one%20that%20resolved%20by%20reinstalling%20video%20drivers%20and%20a%20reference%20to%20.Net%20software.%3C%2FP%3E%3CP%3E-%20rebooting%20my%20system%3C%2FP%3E%3CP%3E-%20looking%20for%20new%20video%20drivers%20(no%20results%20found)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20have%20any%20suggestions%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20sytem%20specs%20are%3A%3C%2FP%3E%3CP%3EProcessor%3A%20Intel%20Core%20i7%206700%3C%2FP%3E%3CP%3EGPU%3A%20MSI%20R9%20380%204GB%3C%2FP%3E%3CP%3ESSD%3A%20Samsung%20Evo%20850%20220%20GB%3C%2FP%3E%3CP%3EHDD%3A%20Seagate%20Barracadu%203%20TB%20(7200%20rpm)%3C%2FP%3E%3CP%3E32%20GB%20RAM%3C%2FP%3E%3CP%3EOS%3A%20Windows%2010%2064-bit%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-4932%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EGoPro%20Studio%20for%20Windows%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-4941%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-4941%22%20slang%3D%22en-US%22%3E%3CP%3EI%20might%20have%20figured%20it%20out.%20I%20was%20using%20two%20rows%20of%20titles.%20After%20deleting%20all%20of%20them%20it%20suddenly%20worked%3B%20i%20can%20save%20to%201080p%20MP4%20again%20%3A).%20Weird%20though....%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStill%20looking%20for%20the%20explanation%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-5011%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-5011%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F3053%22%20target%3D%22_blank%22%3E%40jp3113%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20for%20the%20update.%20I'm%20glad%20that%26nbsp%3Byou%20were%20able%20to%20resolve%20your%20issue%20regarding%20your%20exporting.%20Based%20on%20this%20exporting%20error%20message%2C%20we%20often%20see%20this%20issue%20in%20various%20settings.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CUL%3E%0A%20%3CLI%3EThe%20exported%20filename%20has%20various%20numbers%20and%20dashes.%20Renaming%20the%20file%20usually%20fixes%20the%20issue.%3C%2FLI%3E%0A%20%3CLI%3EThere%20is%20an%20exisiting%20file%20with%20the%20same%20exact%20filename.%20It%20can%20be%20resolved%20by%20changing%20the%20location%20of%20the%20exported%20file%20(Desktop).%26nbsp%3B%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CP%3EOverall%20as%20a%20test%2C%20I%20would%20advise%20to%20bring%20the%20two%20rows%20of%20titles%20in%20again%20and%20ensure%20the%20file%20name%20is%20simple%20and%20saved%20to%20another%20location.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-5047%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-5047%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F28%22%20target%3D%22_blank%22%3E%40jasonc%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20suggestions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-%20The%20filame%20doesn't%20have%20any%20numbers%20or%20dashes.%26nbsp%3B%3C%2FP%3E%3CP%3E-%20I%20tried%20exporting%20with%20a%20different%20filename%20(i%20was%20indeed%20using%20the%20same%20one)%3B%20unfortunately%20that%20didn't%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20made%20some%20progress%20on%20my%20movie%20meanwhile%2C%20including%20two%20rows%20of%20titles%20again.%20I%20forgot%20about%20the%20font%2C%20maybe%20i'm%20using%20another%20one%20now.%20Could%20that%20be%20the%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-5258%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-5258%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F3053%22%20target%3D%22_blank%22%3E%40jp3113%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIt%20could%20be.%20Keep%20us%20posted%20if%20you%20have%20any%20other%20issues.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-6375%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-6375%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20exactly%20the%20same%20issue%3A%26nbsp%3BError%20Preparing%20ExporterEncoderFileWriter%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20no%20titles.%3C%2FP%3E%3CP%3EJust%20a%2040min%20video.%3C%2FP%3E%3CP%3EI%20can%20export%20smallers%20videos.%3C%2FP%3E%3CP%3EI%20have%20enough%20espace%20on%20the%20hard%20disk%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-6397%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-6397%22%20slang%3D%22en-US%22%3E%3CP%3EThat's%20weird.%20Have%20you%20checked%20the%20following%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-%20Removing%20the%20last%20clip%2C%20clip%20by%20clip%3F%20To%20check%20whether%20or%20not%20there's%20a%20corrupt%20file%3F%3C%2FP%3E%3CP%3E-%20Have%20you%20installed%20exotic%20fonts%20on%20your%20computer%20(although%20not%20used%20in%20your%20movie)%3F%3C%2FP%3E%3CP%3E-%20Does%20windows%20eventlog%20provide%20any%20info%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-6604%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20Preparing%20ExporterEncoderFileWriter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-6604%22%20slang%3D%22en-US%22%3E%3CP%3EFixed.%20The%20issue%20a%20video%20of%2010%20minutes%20lenght%20inside%20the%2040%20min.%20I%20just%20spplited%20in%204%20videos%20of%202%20min%20each%20and%20voila!!!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Highlighted
Anonymous
Posts: 0
Accepted Solution

Error Preparing ExporterEncoderFileWriter

Hi there,

 

I'm creating a movie and exporting my progress evey now and then. A couple of times I've succesfully exported using the HD 1080p option to .mp4. Now however, I'm having issues exporting the same movie. I've made some progress, the movie now lasts 11 minutes instead of 6. No big deal, you would think.

 

When exporting I get the error "error preparing ExporterEncoderFileWriter". Only when exporting to avi (much bigger files :( ) i can get a result. It's really weird, because it is the exact same movie that could be exported to .mp4 a few days ago, but now, won't.

 

I've tried the following

- searching for the issue on this forum: no results

- googling the error. I found some small threads, one that resolved by reinstalling video drivers and a reference to .Net software.

- rebooting my system

- looking for new video drivers (no results found)

 

Do you have any suggestions? 

 

My sytem specs are:

Processor: Intel Core i7 6700

GPU: MSI R9 380 4GB

SSD: Samsung Evo 850 220 GB

HDD: Seagate Barracadu 3 TB (7200 rpm)

32 GB RAM

OS: Windows 10 64-bit

error.PNG

Accepted Solutions
Anonymous
Posts: 0

Re: Error Preparing ExporterEncoderFileWriter

I might have figured it out. I was using two rows of titles. After deleting all of them it suddenly worked; i can save to 1080p MP4 again :). Weird though.... 

 

Still looking for the explanation

View solution in original post


All Replies
Anonymous
Posts: 0

Re: Error Preparing ExporterEncoderFileWriter

I might have figured it out. I was using two rows of titles. After deleting all of them it suddenly worked; i can save to 1080p MP4 again :). Weird though.... 

 

Still looking for the explanation

GoPro
Posts: 269

Re: Error Preparing ExporterEncoderFileWriter

Hi @Anonymous

 

Thanks for the update. I'm glad that you were able to resolve your issue regarding your exporting. Based on this exporting error message, we often see this issue in various settings. 

 

  • The exported filename has various numbers and dashes. Renaming the file usually fixes the issue.
  • There is an exisiting file with the same exact filename. It can be resolved by changing the location of the exported file (Desktop). 

Overall as a test, I would advise to bring the two rows of titles in again and ensure the file name is simple and saved to another location.

 

 

Anonymous
Posts: 0

Re: Error Preparing ExporterEncoderFileWriter

Hi @jasonc,

 

Thanks for your suggestions.

 

- The filame doesn't have any numbers or dashes. 

- I tried exporting with a different filename (i was indeed using the same one); unfortunately that didn't work.

 

 

I made some progress on my movie meanwhile, including two rows of titles again. I forgot about the font, maybe i'm using another one now. Could that be the issue?

GoPro
Posts: 269

Re: Error Preparing ExporterEncoderFileWriter

@Anonymous

 

It could be. Keep us posted if you have any other issues. 

Anonymous
Posts: 0

Re: Error Preparing ExporterEncoderFileWriter

I have exactly the same issue: Error Preparing ExporterEncoderFileWriter

 

I have no titles.

Just a 40min video.

I can export smallers videos.

I have enough espace on the hard disk

Anonymous
Posts: 0

Re: Error Preparing ExporterEncoderFileWriter

That's weird. Have you checked the following?

 

- Removing the last clip, clip by clip? To check whether or not there's a corrupt file?

- Have you installed exotic fonts on your computer (although not used in your movie)?

- Does windows eventlog provide any info?

Anonymous
Posts: 0

Re: Error Preparing ExporterEncoderFileWriter

Fixed. The issue a video of 10 minutes lenght inside the 40 min. I just spplited in 4 videos of 2 min each and voila!!!