Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
GoPro Apps for Desktop
Posts: 2

Re: Can`t login, still "Authenticating..:" without effect

I tried that and it worked for the first time, then after rebooting my machine it hangs on authentication again.

I have no Plus subscription.

How about you rewrite this app from scratch and make it work already, for god's sake? It's been in this state for over 2 years now. Where did your QA team go?
Posts: 10

Re: Can`t login, still "Authenticating..:" without effect

Hi @aragon1006,


Nope. i did not do any subscription with GoPro Plus

The existing Quik is having problem already..dont think i have the confident to go for PLUS at the moment.

Posts: 10

Re: Can`t login, still "Authenticating..:" without effect

ya @karolj7546, i have the same things as well..most of the steps is ok for first time log-in only. than once u close the apps and reopen it, it will just go back to the problem again. 


Feel funny to have a lot GoPro account right? once hang then create new account again??


Honestly, i already gave up and trying other apps. 

Posts: 18

Re: Can`t login, still "Authenticating..:" without effect

As I have been telling people for the past 2 years on this problem, FORGET CONTACTING SUPPORT they have NFI how to fix the issue.

GoPro HAS TO COMPLETELY RE-ENGINEER the App from the ground up.

There is no other way that this issue can be resolved.


There is a major bug in the software, and any other company would have been on top of this and got it sorted out.

Go Pro is ONLY interested in selling units, NOT the accompanying editing software.


I personally have gone back to using Apple's iMove with relative success and can do picture in picture and add several sound tracks. The only thing it wont do is add the abiltiy to edit more than 2 cameras, but, I can live with that.


The thing is, iMovie WORKS !!!!


MESSAGE HERE: Don't waste your time with Support because I have been reading their same lame suggested "fixes" for 2 years now !!!



Fishing Cement Works.jpg
Posts: 10

Re: Can`t login, still "Authenticating..:" without effect


Ya..totally agreed on your statement. 


Im using Imovie as well..just one things that imovie unable to do (eg.Capture photo from video)..others is much more better than Quik..Im trying to use Quik is only because that im a GoPro user and there do provide video template.


Ya..the point here is..Quik is not working..!! but others software yes!!

Posts: 12

Re: Can`t login, still "Authenticating..:" without effect

[ Edited ]

So, here is the solution:

All over this forum the suggested solution is to add an entry to the hosts file. This is confusing because there is already an entry for localhost in the hosts file in Mac OS X. The underlying issue is how the code parses the hosts file (I don't know what the code does with the information). My best guess is that the programmer who wrote the code had a hosts file with the localhost entry on the first line in his development environment. Anyway, the solution to the "authenticating" issue is to make your hosts file look exactly the same as the one in the programmers programming environment. So:


What we want to do:

A. Edit the hosts file. The hosts file is locked for editing in its original location so you need to make a copy that you can edit outside the original location before replacing the original hosts file.


1. Make sure you are logged in as an administrator

2. Open a Finder window

3. In the application meny, select Go->Go to Folder and enter /private/etc/hosts

3. Copy the hosts file

4. Paste the hosts file on your desktop

5. Double-click on the hosts file on your desktop to edit it

6. Move the localhost entry to the very top of the file. Note that it is imperative that the entry is at the very top of the file

7. Close the editor (you will not be asked if you want to save the file)

8. Copy the edited hosts file on your desktop

9. In the Finder window, once again select Go->Go to Folder and enter /private/etc/hosts 

10. Paste the edited hosts file. A popup dialog box with the question "An item named “hosts” already exists in this location. Do you want to replace it with the one you’re moving?" Click Replace 

11. Turn Wi-Fi Off

12. Turn Wi-Fi On

13. Launch Quik and sign in.


Please find attached a photo that shows the original and edited hosts file 




quik solution.jpg
Posts: 1

Re: Can`t login, still "Authenticating..:" without effect

[ Edited ]

I can confirm after hours of messing around with this on my new 2018 MBP, the post @dominicm3586 posted works. Go to the link here: follow their steps using X-Edit and follow the post writing the code into you hosts file. Mine was greyed out... Couldn't drag over to the desktop to edit and this was my only option. Saved what I wrote in the file (which was originally empty, no text) and re-opened the app. Everything is now working!!!


Good luck!

Posts: 1

Re: Can`t login, still "Authenticating..:" without effect

[ Edited ]

I have confirmed that the solution provided by @connyf668:


"Move the localhost entry to the very top of [your /etc/hosts] file."


is the right solution!!!


Thank you @connyf668 for figuring that out. Smiley Happy This has been the most perplexing problem I've ever encountered with a piece of software; and is a sad testament to GoPro's ability to support their software. I primarily use this app for syncing the clock and for the occassional firmware update of my GoPro. It's also handy for copying files off without having to extract the tiny SDCard from the GoPro.


I dislike using the iOS and Android app because it just doesn't work well. Getting the wifi connection to work is so fraught with problems I just finally gave up. 


Thank you again, @connyf668 for clarifying the real solution to the problem, you made my day, my week and my month!