Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Posts: 2

hero4 silver wont turn on after update v5

So ive got a hero4 silver that beofre this issue has a damaged front lcd, but works 100% fine apart from not being able to view the front lcd. I attached it my new phone and it immediately reccomended i update it to v5. I i attempted the update wirelessly, but it got to the end and apparently failed. the camera was still working fine and mulitple sources on the internet said to try again with the update. This time it completed fine, according to the app on my phone, but the camera was just flashing the red leds over and over again.

i tried holding down the power button and it would turn straight back on, same if i removed and replaced the battery. it finally stopped beeping, presumeably because the battery died. but now it wont turn on at all.


i tried formating the sd card, and tried the same with 2 other sd cards (sandisk 64gb extreme plus) and a different battery and nothing has worked.

i tried multiple different button combinations that were supposed to hard reset the camera.

i tried turning it on with the sd card and battery removed, and attached to the wall and the computer. when plugged into my windows 10 desktop the computer recognises a device that malfunctioned so cannot be loaded.

i tried leaving it battery and sd removed for a few hours, and reattempted everything above.


ive seen so many people with the same or similar problem and while some have been able to fix it with the above techniques, im worried im in the group of unfortunate individuals who seem to have ruined an expensive peice of equiptment while trying to update it with the correct firmware, through the gopro app.

please someone tell me theres a fix i havent tried. i really dont want to have to scrap this thing.



Posts: 2

Re: hero4 silver wont turn on after update v5

Forgot to say that when I've tried manually updating it with a sandisk 64gb extreme plus, formatted exfat, and a sandisk 16gb ultra, formatted fat32. It just doesn't turn on.
Also I've tried charging the battery, but nothing lights up.