Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Sightseer
Posts: 2

hero 5 unresponsive

flashing red lights and exclamation mark in front display.  Camera is unresponsive.  help!

Highlighted
GoPro
Posts: 12,876

Re: hero 5 unresponsive

Hi @richardp177

 

Try to take the SD card and the battery out.

Plug the camera directly to a power source and see if it turns on.

Replace the battery then try it again.

If it powers on, proceed with a manual update.

If it still fails, please reach out to our Support Team through https://gopro.com/help/ContactUs

 

Thanks!

Ej

Highlighted
Sightseer
Posts: 2

Re: hero 5 unresponsive

I took the battery and sd card out, plugged it in to a power source, and same blinking red lights and exclamation point.  Gopro was still unresponsive.  

 

I tried the online chat, but no response after 10 minutes.  Maybe I'll try again.... 

Highlighted
GoPro
Posts: 5,870

Re: hero 5 unresponsive

Hi @richardp177,

 

If you haven't tried updating your camera manually please try to do it first. 

If issue persist you may contact GoPro Customer Support. 

 

-Jay 

Highlighted
Tourist
Posts: 3

Re: hero 5 unresponsive

how does one do a manual update, if the red light keeps flashing, and the front display shows and exclaimation point?

Highlighted
Tourist
Posts: 3

Re: hero 5 unresponsive

i used YouTube to figure it out. you all aren't very responsive or helpful. my survey will relay as much.

Highlighted
Adventurer
Posts: 11,681

Re: hero 5 unresponsive

what the Moderator may be saying is he wants to see if the camera  can update if it is in that state. if not his next reply will be to

 

Contact these  links:

 

Chances are slim that it will accept a firmware in that state. Never know.

 

Fish

Highlighted
Tourist
Posts: 3

Re: hero 5 unresponsive

i actually did accept the firmware in the flashing-light state it was in. i got the fix from a 2 y/o YouTube video. the Cust. Support folks should be better than not knowing the proper fix that’s existed for about 2 years. what are they getting paid for?