Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Tourist
Posts: 3

WiFi off hero 8

I'm trying to switch WiFi off to save battery but when I turn it off in the menu it immediately awitches itself back on,I'm not connected to the app either on my iPhone 

Highlighted
Nomad
Posts: 3,816

Re: WiFi off hero 8

I just tried to replicate this with my own GoPro Hero 8 but once I go into the GoPro 8 preferences and turn off the wireless connections, they stay turned off.  You could have faulty firmware and may need to do a manual update:

Highlighted
Tourist
Posts: 3

Re: WiFi off hero 8

Thanks I've just tried to update but I'm guessing 1.60 is the latest as I've only had the hero8 today,strangely I tried again and it now switches off...don't know what was going on lol

 

 

Highlighted
GoPro
Posts: 8,627

Re: WiFi off hero 8

@trevh5772, reinstalling the firmware update of the camera can also help correct any errors with the current software installation. Using an SD card adapter, connect your microSD card to your computer and follow the Manual Update instructions specified in this article: https://community.gopro.com/t5/en/How-to-Update-GoPro-Cameras/ta-p/394229 

 
Additionally, performing a factory reset in the camera may help. 
 
Let us know how it goes. 

Highlighted
Tourist
Posts: 3

Re: WiFi off hero 8

Thanks it seams to have sorted that issue,I just have trouble getting the screen preview to work on my iPhone xs,I’ve found now if I forget this network in the WiFi settings on my phone it works until the next time I have to do the same,this only started happening after the latest iOS update,it’s not a biggy now as I only needed to setup the position on my chesty for MTB,I can judge it now by eye so I’ve turned all connections off on the GoPro to save precious battery👍
Highlighted
GoPro
Posts: 14,544

Re: WiFi off hero 8

Great to know that the issue has been sorted out, @trevh5772. Thank you for posting back to share the resolution that you found.