Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 5

Re: Webcam Function not working on Hero 9

[ New ]

Hi, 

 

Go Pro wont help you here (or anywere).

 

But you can look forward to other users suggesting you invest time with DIY.

 

Me hate Go Pro! Hail satan!

Sightseer
Posts: 2

Re: Webcam Function not working on Hero 9

[ New ]

I have same problem om Mac but on Windows 10 it's work.

Tourist
Posts: 5

Re: Webcam Function not working on Hero 9

[ New ]

Facing same issue of not detecting the Hero 9 on Mac . 

 

I have been using the canon webcam utility with both the Canon DSLR as well as mirrorless and it simply detects  the cameras flawlessly on connecting the USB cable . 

Why is GoPro folks struglling to get this working i wonder . Its supposed to be a simple thing given the technology  is available .

 

It's a shame to see that gopro team dont even respond to these inspite of people posting it  in the forums . Atleast they must test and provide some updates frequently .  

 

GoPro
Posts: 28,953

Re: Webcam Function not working on Hero 9

[ New ]

Hi @daringridg8612

 

What USB connection setting is your camera on?

See Camera is not Recognized when Plugged into a Computer USB Port

 

What version of the webcam app are you using?

You may also check the steps on GoPro Webcam FAQ and Troubleshooting 

Let us know how it goes.

 

Thanks!

Ej

Tourist
Posts: 5

Re: Webcam Function not working on Hero 9

[ New ]

Am using the camera with a macbook running 10.14.3 ( which is supposed to work ) . The USB connection is to a hub USB C to USB 3.0 hub  which works with all devices including the canon camera . Am using the USB cable that came with gopro . The camera gets detected when plugging in also stating configure to network preferences when plugged in( no idea why thats necessary )  . Also am using the GoPro connect setting enabled in the camera 

 

Looks like the problem is not listed in the FAQ or troubleshooting section. 

 

Surprising that other webcam utilities work perfectly fine while this one struggles .  its quite a useful feature and have no idea how it doesnt work reliably for so many.  Doesnt gopro use log files to check whats going on ? 

Please check the implementation of the gopro webcam utility application.  

Sightseer
Posts: 2

Re: Webcam Function not working on Hero 9

[ New ]

I was facing similar issues in Win10, 64bit, where preview was not working and specifically Zoom as well.

 

Issue is directly tied to corporate managed VPN, Cisco AnyConnect. When VPN is disconnected, camera functions as expected. Unfortunately I need to be on VPN nearly all day so this needs to be addressed if possible.

Tourist
Posts: 5

Re: Webcam Function not working on Hero 9

[ New ]

in corporate machines if the USB or VPN  blocks external camera connections or ports its a different issue  altogether, but when the camera itself is not detected when connected on a normal machine it  hints a  issue with software where some service discovery mechanism is not working as reliably or as expected.

 

As mentioned in my post a similar application which works over USB ( canon ) does it so seamlessly while gopro is not even detected and even  there is no hint of what the reason is using some log files . 

Gopro  folks may need to look at other app designs and re-engineer perhaps . I also wonder given there is wifi support on the camera why there is no support for wireless video to desktop using the same application . This must be possible .  A webcam feature is so useful in cameras these days and i hope gopro gives some due attention to fix and develop these features . 

 

 

 

Sightseer
Posts: 1

Re: Webcam Function not working on Hero 9

[ New ]

I work with Mac Os Big Sur and Hero 9 with MS Teams. The Webcam app works perfectly with the go pro alone, but the Hero with the Media module no longer works (it worked last week)
The operation is really very random.

GoPro
Posts: 28,953

Re: Webcam Function not working on Hero 9

[ New ]

Hello @daringridg8612

 

If you continue to get the same after going through the steps shared on the links above, please let our Support Team know.

You may submit a request for a callback or initiate a chat session through https://gopro.com/help/ContactUs
Please let them know of the troubleshooting steps taken.
 

Thanks!

Ej

Tourist
Posts: 2

Re: Webcam Function not working on Hero 9

[ New ]
Yeah, I just had a chat with Gopro about this same problem on the 9 black. Now it won't even connect the wifi to my phone after doing what they asked me to try. Although they did there best, It made things even worse.

Plz, If anyone knows a solution or a workaround to use it as a webcam, I'd be glad to know about it.
Sightseer
Posts: 1

Re: Webcam Function not working on Hero 9

[ New ]
My GPH9 not working as webcam in Windows 10 recently. After few hours doing a lot of troubleshooting, I try uninstall my Avast Premier antivirus and VOILA!!!, GPH9 working as webcam. U may try coz maybe your antivirus not allowed or blocked the gopro apps
Sightseer
Posts: 1

Re: Webcam Function not working on Hero 9

[ New ]

Solution: right click the icon and go to preferences (or it might say 'Graphics' or something) change your graphics card settings. I'm on a PC and i had to change it from NVIDIA to Intel. Also I had to unplug the camera, turn it off and on, and plug it back in before it would work. Give it a try. Im sure there is a simalar option on mac

Tourist
Posts: 5

Re: Webcam Function not working on Hero 9

[ New ]

It is not the same issue on mac.  

Sightseer
Posts: 1

Re: Webcam Function not working on Hero 9

[ New ]

Same here.....but i find which the issue.

 

seems like gopro webcam software creates temporarly some network conenction to tranfer the image.

 

1) when you go at avast firewall settings you will see your existing conenctions

2) then connect your webcam and power on

3) after some seconds or minute a new connection will apeared there at avast firewall settings with Public marked.

4) mark this new conenction in avast, as Private and webcam will work ok

 

Or  if already its on Private (mine wasnt), and still not working, then try to disable the avast firewall protection only and see if then works.

 

 

Sightseer
Posts: 1

Re: Webcam Function not working on Hero 9

[ New ]

SO GOPRO WHERE IS THE UPDATED INFO.  IT SHOULDNT BE THIS HARD!   YOUR REPUTATION AS BEING INCOMPETENT AND DEALING WITH CUSTOMER ISSUES IS GROWING RAPIDLY

GoPro
Posts: 20,607

Re: Webcam Function not working on Hero 9

[ New ]

Hello, @bmadbmad. Are you still having issues using the webcam utility tool? Which computer OS do you have? 

Tourist
Posts: 3

Re: Webcam Function not working on Hero 9

[ New ]
Same here.
Only get a black preview window under windows 10.
Should be possible to fix that if it works for others.
GoPro
Posts: 28,953

Re: Webcam Function not working on Hero 9

[ New ]

Hi @je0715

 

What version is the camera on?

Were you able to go through the steps on GoPro Webcam FAQ and Troubleshooting?

 

Thanks!
Ej

Tourist
Posts: 3

Re: Webcam Function not working on Hero 9

[ New ]
The GoPro has version 2.5
Yes I went through the troubleshooting steps, but still the same.
Tourist
Posts: 2

Re: Webcam Function not working on Hero 9

[ New ]

Just want to add my frustration with this joke of a webcam utility.    Good luck getting it to stay in webcam mode if you do get it to work.  Tried it with a battery and without.   Without a battery it will power up and sometimes go into webcam mode.  Sometime within two minutes it shuts off.  If I put a battery in it, the device will power up and only go into "USB Connected" mode.   

When it does work, the quality is awful.   I'm not trying to compare it to other actual cameras that I have, I'm just saying the quality is awful.  The resolution is worse than my 5yr old son's $20 digital camera I bought off of Amazon.    Yes, I've seen the pictures people have posted with their settings in OBS, and I've watched the Youtube videos, but I have had zero luck getting this to work properly. 

 

Another part that makes this situation that much worse, there's no way to adjust the settings while in webcam mode.  Apparently there used to be an option but it was disabled.  This is horrible because it defaults my white balance to a rediculous extreme.   

 

Absolute garbage.    

 

I'm using usb 3.0 directly into the camera.    

 

Now here's the OTHER issue...  When I connect it to a Micro-HDMI cable, while using the overpriced Media Mod case, it shows an HDMI symbol on the front screen and no menu control whatsoever.   When I hit the mode button, it started playing previously recorded videos!    I'm running the HDMI into an Avermedia DUO PCIe capture card which is rock solid and never gives me problems.   

 

So far my experience with GoPro is that it's nothing but overhyped garbage.    Regretting that I spent $50 for the annual package as this POS is going on fleabay this afternoon. 

 

 

Tourist
Posts: 3

Re: Webcam Function not working on Hero 9

[ New ]
Totally understand your frustration. Especially when other companies seem to be able to develop and provide a proper solution to use cameras as a webcam.
Still don‘t understand why this solution is creating and using a network connection for the video signal.
Not sure if this is even a clever way when it comes to security concerns.

I thought it will be working straight forward, but to spend time to get this working.

Tourist
Posts: 2

Re: Webcam Function not working on Hero 9

[ New ]

yeah, after the last update of the w10 app, it does it for like 10 seconds and that it freezes. It doesn't matter if I use the preview or an app like Zoom.

When I contact Gopro, they want me to do a clean install on my Gopro. The last few times, that only made things worse.

Besides, the camera itself was never the problem it's the W10 app.

 

To me, it feels like they messed things up, and we have to take the affort to solve there own problems.

I really wonder when they take responsibility and fix it them selves. Or atleast heavely test there own updates to make sure it doesn't make things worse.

Sorry if I'm a bit rude or to direct, but that's just how I feel about it.