Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Posts: 2

Unable to load media in GoPro App

I have a GoPro Hero 6. I can connect it to the GoPro app and watch live preview of the camerafeed through the app. I am able to initiate recordings of photo and video from the app, and those photos and videos show up when I go to view media on the camera. However, when I try to view or download media to the phone app I get verious error messages. One says something along the lines of «Can’t connect. Make sure your GoPro is ready to share media». How do I make sure that the GoPro is ready to share media? Another error message says something like «We can’t load your media. Power cycle the camera and try again.» I’ve tried that but it does not work. I’ve tried resetting the connection with the phone, but that does not help. The SD card is a SanDisk UItra Extreme 64GB card purchased through my local camera shop. My phone is an iphone X. I am currently on vacation so I don’t have access to a computer for the next two weeks. Is there any way to access my photos and videos? 

Posts: 8,334

Re: Unable to load media in GoPro App

Hello @sunnyboost666


The SD card that you are using is a not a recommended one. Ultra cards may initially work with GoPro cameras but they have been found to exhibit issues eventually. Try a different SD card if you have another one available. We highly recommend using one of the cards on this list.


Also check if you have the latest firmware on your camera by going to Preferences, then About this GoPro. The latest version is 2.01. We would typically ask to get the camera manually updated for this case, even if the camera already has the latest firmware, but that would need access to a computer. 


By any chance, was your mobile data on when the camera was paired up with your iPhoneX? See if turning it off matters. Is your phone updated to its latest OS version? Make sure that it is. 


Let us know how it works out considering the information above. 



Posts: 2

Re: Unable to load media in GoPro App

So, upon closer inspection I can see that my SD card is NOT an Ultra. Just Extreme.

The camera is on version 2.0.1.

My phone was using mobile data when I tried to connect the camera. Haven’t tested whether it makes a difference.

I sorta found a workaround. I was able to purchase that Apple Lightning to SD card adapter as well as a microSD to SD card adapter. By using those two things I can get access to all my videos and photos. Interestingly the media is not imported chronologically but that’s a minor issue at this point.