Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Is your GoPro gear up to date? Check to see If it is on our Update page.
Posts: 1

Quik for desktop Mac won't show Camera info or files

It doesn't show the camera name, nor the SD file size (let alone contents). It does show it has connected to a camera but nothing else. I cannot import files.

I am attaching screenshot where you can see that Android File Transfer does show the SD contents at the same time and the folder's name in it are ok.

Have rebooted many times but still doesn't work.

Quik version

MacOS High Sierra 10.13.6

GoPro Hero 6


GoPro 6 Issue.jpg
Posts: 18,755

Re: Quik for desktop Mac won't show Camera info or files


Thank you for the information @mcaddress


Please go over the steps listed on this article.

As an alternate option, you may use and SD card adapter to import your files.


If this option will not work for you, please reach out to our Support Team for further troubleshooting.

Please let them know of the steps you have taken, they may also ask you for your computer's specs.





Posts: 2

Re: Quik for desktop Mac won't show Camera info or files

Hey please let me know if you find a fix I'm having the same problem on Mojave. I have tried reinstalling Quik, updating my GoPro twice, formatting my memory card and resetting my PRAM. I wasted 2 hours with the live chat support they made me do everything I already did the only thing they could think of was my SD not being supported on the older models (Samsung EVO Plus 128GB), but I don't believe this is the issue because everything has worked flawlessly. I think its a software or firmware issue.