Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Sightseer
Posts: 2
Accepted Solution

Problem with hero session powering on

I just got my go pro hero session and it worked for a day but then I accidentally pressed record without a SIM card in it and it said "No SIM Card" then beeped then powered off. But it is slightly warm. I try to press the small button on the back but nothing happens.

Stefan

Accepted Solutions
Highlighted
GoPro
Posts: 6,097

Re: Problem with hero session powering on

 

Thank @swagmansteve!

I would suggest to change your SD card and manually update your firmware. 

 

 

Use this link instead or copy and paste this to browser: https://gopro.com/update

Click on product Updates and choose HERO Session 

Click Update your Camera Manually and then type in your serial number and email address. 

Follow on screen instruction and that should fix the issue. 

 

With regards to changing your SD card please use this guide. 

https://gopro.com/help/articles/block/microSD-Card-Considerations

 

Best Regards,

-Jay 

View solution in original post


All Replies
Highlighted
GoPro
Posts: 6,097

Re: Problem with hero session powering on

 

Hi @swagmansteve

 

May I know what is the brand and model of your SD card?

Also have you tried manually updating the firmware? 

 

Here's how. 

 

Format your SD card.

 

Go to this website: https://gopro.com/update/hero_session

and click update your camera manually. 

 

After that type in your serial number and email address. 

 

Follow on screen instruction. 

 

Let us know if that will work, 

 

 

Regards,

-Jay 

Highlighted
Sightseer
Posts: 2

Re: Problem with hero session powering on

Hi Jay, I pressed the link but it didn't give me anything to type on or click, also my sd card is a silicon power elite 64gb
Highlighted
GoPro
Posts: 6,097

Re: Problem with hero session powering on

 

Thank @swagmansteve!

I would suggest to change your SD card and manually update your firmware. 

 

 

Use this link instead or copy and paste this to browser: https://gopro.com/update

Click on product Updates and choose HERO Session 

Click Update your Camera Manually and then type in your serial number and email address. 

Follow on screen instruction and that should fix the issue. 

 

With regards to changing your SD card please use this guide. 

https://gopro.com/help/articles/block/microSD-Card-Considerations

 

Best Regards,

-Jay