Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 5

My go pro 8 won't connect to my iMac

[ New ]

My go pro 8 won't connect to my iMac.

GoPro
Posts: 28,708

Re: My go pro 8 won't connect to my iMac

[ New ]

Hi @snowyhero58168

 

Are you getting an error message?

Check out Camera is not Recognized when Plugged into a Computer USB Port 

 

Thanks!
Ej

Tourist
Posts: 5

Re: My go pro 8 won't connect to my iMac

[ New ]

I am not getting any message nor is it showing up in my finder. I also checked to see if photos would open it and that dosen't work either.

GoPro
Posts: 20,523

Re: My go pro 8 won't connect to my iMac

[ New ]

Hello, @snowyhero58168. Make sure that your camera is in MTP mode. To do this, go to Preferences, then Connections, then USB Connection, then MTP. This should allow the transfer of media from the camera to your computer.

Tourist
Posts: 5

Re: My go pro 8 won't connect to my iMac

[ New ]

I have tried everything and neither my desktop nor my laptop will recogninze my gopro8.  

GoPro
Posts: 14,905

Re: My go pro 8 won't connect to my iMac

[ New ]

@snowyhero58168, just to check, are you using the GoPro USB cable that came with the camera package? Have you also been able to update your HERO8 Black camera's firmware?

Tourist
Posts: 5

Re: My go pro 8 won't connect to my iMac

[ New ]

Yes, software is up to date 02.50.00 and using the gopro cable that came with the camera.

GoPro
Posts: 20,523

Re: My go pro 8 won't connect to my iMac

[ New ]

Is it only when using a cable to connect the camera to your computer that the connection is not detected? See if inserting the camera directly to your computer through an SD card adapter allows the media to be recognized. 

 

To further isolate the issu. try doing the same process (cable connection/SD card insert) using a different computer if accessible. Let us know how it goes. Thanks!