Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Sightseer
Posts: 1
Accepted Solution

Menu display problem

I have the Hero Session. The menu is not displaying any information. The blue light is continuing to flash and the camera is fully charged. Any suggestions of how to get the menu to work before I take this back to the store and exchange it?


Accepted Solutions
GoPro
Posts: 9,299

Re: Menu display problem

Hello @tbielski3

 

The blue light that is flashing is an indication that the camera's Wi-Fi is on. When you mentioned that the camera us fully charged, did you mean that the red light turned off eventually while the camera was charging? It is odd for the display to not show any information at all. Try this: while the camera is connected to a power source, press the back button (with the Wi-Fi signal) and see if you get the USB with battery symbol displayed on the screen. If it does not show up and your camera is newly-purchased, you can go with an exchange. It would be better to test the camera at the store then (if allowed). 

 

Thanks, 

Marius

View solution in original post


All Replies
GoPro
Posts: 9,299

Re: Menu display problem

Hello @tbielski3

 

The blue light that is flashing is an indication that the camera's Wi-Fi is on. When you mentioned that the camera us fully charged, did you mean that the red light turned off eventually while the camera was charging? It is odd for the display to not show any information at all. Try this: while the camera is connected to a power source, press the back button (with the Wi-Fi signal) and see if you get the USB with battery symbol displayed on the screen. If it does not show up and your camera is newly-purchased, you can go with an exchange. It would be better to test the camera at the store then (if allowed). 

 

Thanks, 

Marius