Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Tourist
Posts: 2

Media Mod not outputting an HDMI signal?

[ Edited ]

So I have a Hero 8, with the GoPro Media Mod. I want to use it as a web cam. I am running an HDMI out to a Razer Ripsaw HD (Capture Card).
I am not getting an HDMI signal from the GoPro to any device though. So I thought maybe its the cable, so I bought a second HDMI mini to standard, and still nothing. So then I thought, maybe its the Razer Ripsaw, so I ran the GoPro straight to the TV, and still nothing.
I've tried powering the GoPro with the USB-C charger plugged in, and with just the battery in. I've tried this with an SD card in, and out.
Another symptom worth mentioning is that, the TV and the Razer both indicates that they see a device but its always a black screen. My TV says that there is a device in the specific port, and my Razer Ripsaw pops up a notification that a device has been unplugged when I remove it.
Last thing I should mention is that, when I swipe down, go to Preferences and select Input/Output, it only says "Audio Input N/A". I believe I saw a few videos on Youtube giving different options when the Media Mod was connected.
And just to cover any silly mistakes or questions. It does record video to an SD card just fine, so the camera its self is working just fine.
I assumed the problem must be some settings on the camera I have messed up, or the Mod itself could be faulty but I doubt it.

Sorry this is kind of long. I just wanted to cover all the parameters I tested and findings I had.

Highlighted
Tourist
Posts: 4

Re: Media Mod not outputting an HDMI signal?

I was doing the same thing. Honestlt, nothing worked. i Just requested a refund tonight. shipping it back in the A.M. 

 

Highlighted
GoPro
Posts: 13,118

Re: Media Mod not outputting an HDMI signal?

Hello, @roguemike. When the Media Mod is attached to the camera, the Audio Input should indicate Media Mod and not N/A. This indicates that there could be an issue with the camera or the Media Mod for this input to not be detected. This eventually affects how the setup will perform in terms of displaying media via HDMI. 

 

If you have gone through recommended troubleshooting steps already, including manual firmware update, and the issue persists, let our Support team know. They will assist you with the next steps to get this matter sorted. 

 

To connect with Support, visit https://gopro.com/help/ContactUs . Once there, select "Contact Us" and proceed with either chat or a callback request. Be sure to put in your best contact number. 

Highlighted
Tourist
Posts: 2

Re: Media Mod not outputting an HDMI signal?

Before you ship it back, I guess you might as well try what confusing nonsense I went through. I repair arcade machines for a living and sometimes, something that doesn't really make sense ends up fixing it, for an unexplainable reason. And that's kinda what happened with me here.
NOTHING was working, so I updated and downloaded the app. I could get a camera feed to my app, but as soon as I plugged in my HDMI, my screen would go black (On my phone) and say "Can't display while in playback mode, or something similar to that. (That was my first big clue. Clearly the device was going into play back mode and stopping an HDMI signal out.)
Well I gave up and called tech support. We got no where really, but I have to say that dude was patient and tried his best for over an hour or two. He had me manually install an update. And a bunch of other stuff that didn't really do much.
Well after that I tried some more. And I guess here is where the list of things I suggest you try:
Manually update your GoPro. I don't know if this made a difference but its one thing that we did do in the process.
Put your RipSaws HDMI out into another screen. Again something you shouldn't meed to do but it may have had an impact.
Turn on your GoPro with the HDMI plugged into your Ripsaw
Hit the mode/power button twice, maybe 3 times. I can't get it to go to the playback menu now, but if you hit the power/mode button it would cycle to a live view option. Hit the record button to select the option. So try it twice then hit record. If that doesn't work, power it down, turn it on, and hit power/mode 3 times then record. That should bring you to a live record mode. (Note: This isn't a menu I found without being plugged into the HDMI).
STILL non of this really worked till I un installed OBS and reinstalled it, then restart my computer. After that, it magically started working.

I believe manually updating your GoPro, re installing OBS and blindly cycling through the menu should get you there. The Ripsaw itself really is just plug in play. The GoPro just seems to have so many issues...

Ill try to rewrite this in the morning after I get some much needed sleep.