Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 9

Hero8 - Blue dot on main screen

[ New ]

Hi, I just picked up the new Hero 8 and I'm really confused. There is a blue dot on the main screen. You can also see it in the application. Firmware is up to date. The camera is straight out of the box, a few minutes of use.
Any ideas?
https://youtu.be/Ij3fvUtRQFU 
https://youtu.be/k2nlptOqQCY 

Hiker
Posts: 12

Re: Hero8 - Blue dot on main screen

[ New ]

Me and every other person who ordered it has had some issues, i got issues with charging and recording. Best thing call up support open a case and send in for a replacement, it will take at least three weeks to get the replacement.

Tourist
Posts: 9

Re: Hero8 - Blue dot on main screen

[ New ]

I've been trying to contact chat support for four hours. I have Gopro plus and it is a mockery that there are no free agents all this time.
I am going on vacation next week and I do not know what to do now.
These are not bad pixels, because the dot moves when you move the camera.

GoPro
Posts: 24,297

Re: Hero8 - Blue dot on main screen

[ New ]

Hi @pandariusz

 

Sorry if you are having issues connecting.
The chat option should be working.
Try using other browsers. Also, check if your pop-blocker is turned off.

You may also try selecting US-English.

If calling, make sure that your are using a network that allows calls to toll free numbers.

 

 

Thanks!

Ej

Tourist
Posts: 9

Re: Hero8 - Blue dot on main screen

[ New ]

@aragon1006 it's not problem with my browser or pop-ups. I'm trying every few minutes and every time there's a red message "Sorry, all agents are helping other customers right now. Please try again later.". So I'm trying again and again... Annoying...

Tourist
Posts: 1

Re: Hero8 - Blue dot on main screen

[ New ]

Any update on the issue? I have the same blue dot. Camera just came in today.

Hiker
Posts: 22

Re: Hero8 - Blue dot on main screen

[ New ]

I just got my GoPro 8 today too and have the same issue. Mine only shows up when I have Hypersmooth Boost on. It doesn't show up in any of the videos I take though. Does it show up in any of your videos?

 

Edit:

It also shows up on my GoPro App like yours.

 

Edit 2:

I just tried 2.7k boost and the blue dot didn't show up until I switch it to 2.7k 60fps. So doesn't look like it shows up in all settings. Will do more test.

Tourist
Posts: 9

Re: Hero8 - Blue dot on main screen

[ New ]
"You may also try selecting US-English." - This is a protip!

@rapidhike644
I had a long talk with support. The agent was very surprised and consulted the problem with the team. I sent them some additional photos and added some information. Now I have to wait for the email. No clue for now.

@mtbohana
It shows up in video mode, with or without Boost. I think it doesn’t show up in any videos, only on the screen and in the app.

I think you should also start a case with support. They need to know there is a bigger problem.

Can’t wait for any info from support.