Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 4

Hero7 Black and Huawei P10 Plus connection issues

[ New ]

Hi all,

 

I have just received  my Hero7 Black and am having connection issues with my Huawei P10 Plus.

 

I added the camera successfully to the app and changed the name of it successfully. However I could not get the update to work via the app so I did it maually via the sd card. It now has firmware v1.90 installed.

 

The app tells me the camera is connected, but when i choose " Control Camera" it will not connect and comes up with the "We had trouble connecting your GoPro" and the 3 suggestions to try there. Ive tried them all to no avail.

 

I have also tried...

 

* deleting and then finding and reconnecting the device * (successful everytime)

* reset the wi-fi settings on the GoPro (no difference)

* changed the wifi from 6 GHz to 2.4 GHz  - theHuawei P10 Plus supports both (no difference)

* resetting  the GoPro to factory settings and gone through the whole procedure again  (no difference)

 

 When I have gone through the whole process and reconnected/renamed the camera, I am unable to connect even though it says its connected it tells me on the media tab that I have new media and there is an option to get it. The odd thing is , there is no media to get as I havent made a video or taken any photos at that point! If I select get it it tries to connect but doesnt.

 

The camera shows up in my link list of Blutooth devices, but with a name I didnt give it.

 

In the camera Preferences  then "Camera Info" it shows the name that I gave it and a password. What is that for? Should I be using this to connect somehow? I havent been asked for it inany of the things I have tried.

 

Any help on this much appreciated as this is soooo frustrating!

 

Cheers

Roger

 

 

GoPro
Posts: 20,536

Re: Hero7 Black and Hauwei P10 Plus connection issues

[ New ]

Hello, @mayetse. Prior to pairing again, make sure that you delete the camera (maybe named GPxxxx) from the list of Bluetooth devices and forget it as well under available Wi-Fi networks on your phone's settings. Remove the camera from the GoPro App list, too. 

 

Do one more reset on the camera and try pairing again. There are more device-specific troubleshooting steps here for you to try. Let us know how it works out.  

 

 

Tourist
Posts: 4

Re: Hero7 Black and Hauwei P10 Plus connection issues

[ New ]

Thank you for your reply @mariustanya 

 

I will of course follow the sequence you suggest and report back...one question first though...

 

There is no mention of a GoPro wireless network in my phones "available Wi-Fi networks"

 

Should there be?

 

Cheers

Roger


 

GoPro
Posts: 20,536

Re: Hero7 Black and Hauwei P10 Plus connection issues

[ New ]

Not necessarily, @mayetse. But be sure to check for any network that could be referring to your camera. 

Tourist
Posts: 4

Re: Hero7 Black and Hauwei P10 Plus connection issues

[ New ]

I have worked through the following…

 

Huawei P10 Plus

  • GoPro App removed
  • GoPro removed from Bluetooth device list
  • Nothing in the Wireless Networks list
  • Phone restarted
  • GoPro App reinstalled

GoPro Hero 7 Black

  • Factory reset

App found camera and connected allowing name to be changed.

 

Still would not connect via WI-FI, however after trying this time a different message popped up (see image below)

Choosing the option “Retry at 2.4GHz” on the pop up didn’t seem to do the job, but when I changed from 5Ghz to 2.4 GHz on the camera, Hey Presto the WIFI connection worked! Full control over the camera etc. the GopPro now shows up in the list of wireless connections too!

 

As I said previously I had tried changing from 5 Ghz to 2.4 GHz before but there was no success, so maybe I needed to go through the process above.. However using a WI-FI scanning app on my phone I can see the GoPro wireless network when it bis set to 2.4 GHz (along with all other local networks) but when I swith to % GHz WI-FI on the camera no wireless network appears on the scanner at the frequency. Scanner is working fine as it picks up a few others.

 

Is my GoPro likely to be faulty and not actually serving up a 5GHz WI-FI network?

 

Thank you for all your help today  @mariustanya

 

Cheers

Roger

Screenshot_20200514_203503.jpg
Backpacker
Posts: 7,615

Re: Hero7 Black and Hauwei P10 Plus connection issues

[ New ]

Hi Roger

     It all depends on where you are located.  There are some countries in the world were 5GHZ has not been licensed for wireless communication.  This took me by surprise also as I always connect to my camera's via 5GHZ with no issue.  However on a recent trip to Europe I found my 5GHZ WiFi connection would not work, I uninstalled the camera's, uninstalled the app, tried repairing the connections but nothing would work.  It was only when I changed the WiFi bands to 2.4GHZ that I was able to connect.  As soon as I returned to the states though I was able to use 5GHZ again for connection.

 

Hope that helps