Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
%3CLINGO-SUB%20id%3D%22lingo-sub-267340%22%20slang%3D%22en-US%22%3EHero%20session%20camera%20won't%20power%20up%2C%20just%20shows%20solid%20blue%20light%20when%20plugged%20in%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267340%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20GoPro%20Session%20suddenly%20would%20not%20power%20up%20after%20some%20use.%20Tried%20hard%20reset%2C%20a%20new%20SD%20card%2C%20all%20of%20the%20above.%20I%20plugged%20it%20into%20it's%20charger%20and%20see%20a%20SOLID%20blue%20light%20on%20the%20back%20of%20the%20camera%2C%20and%20a%20faint%20but%20also%20solid%20blue%20light%20on%20the%20front%20LED.%20Small%20LED%20screen%20on%20top%20does%20not%20turn%20on%20at%20all.%20My%20computer%20will%20also%20not%20recognize%20the%20camera%20as%20being%20plugged%20in%2C%20most%20likely%20as%20it%20won't%20actually%20fully%20power%20on.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20experienced%20this%3F%20Ive%20seen%20threads%20where%20the%20blue%20light%20is%20flashing%2C%20but%20none%20about%20a%20solid%20blue%20light%2C%20and%20none%20describing%20these%20same%20symptoms.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20is%20appreciated%2C%20thank%20you!%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-267340%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHERO%20Session%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-267351%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%20session%20camera%20won't%20power%20up%2C%20just%20shows%20solid%20blue%20light%20when%20plugged%20in%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267351%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F81486%22%20target%3D%22_blank%22%3E%40graydive3675%3C%2FA%3E%2C%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EPlease%20try%20to%20repeat%20what%20you%20did%20and%20also%20try%20to%20press%20and%20hold%20the%20mode%20button.%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EIf%20issue%20persist%20please%20contact%20our%20customer%20support%20team%20via%20phone%20or%20chat.%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3ERegards%2C%3C%2FP%3E%0A%0A%3CP%3E-Jay%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-267748%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%20session%20camera%20won't%20power%20up%2C%20just%20shows%20solid%20blue%20light%20when%20plugged%20in%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267748%22%20slang%3D%22en-US%22%3E%3CP%3Esame%20issue%20here!%20Still%20waiting%20for%20THE%20answer%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-267749%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%20session%20camera%20won't%20power%20up%2C%20just%20shows%20solid%20blue%20light%20when%20plugged%20in%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267749%22%20slang%3D%22en-US%22%3E%3CP%3Esame%20issue%20here!%20Still%20waiting%20for%20THE%20answer.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-269832%22%20slang%3D%22en-US%22%3ERe%3A%20Hero%20session%20camera%20won't%20power%20up%2C%20just%20shows%20solid%20blue%20light%20when%20plugged%20in%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-269832%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Fcommunity.gopro.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F81626%22%20target%3D%22_blank%22%3E%40achsa%3C%2FA%3E%2C%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EHave%20you%20tried%20using%20other%20cable%3F%3C%2FP%3E%0A%0A%3CP%3ETry%20to%20charge%20it%20using%20other%20cable.%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3ETry%20to%20press%20and%20hold%20the%20mode%20button.%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EIf%20it%20won't%20work%20contact%20our%20customer%20support%20team.%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3EThey%20can%20help%20you.%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fgopro.com%2Fhelp%2FContactUs%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgopro.com%2Fhelp%2FContactUs%3C%2FA%3E%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3ERegards%2C%3C%2FP%3E%0A%0A%3CP%3E-Jay%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Reply
Highlighted
Sightseer
Posts: 1
Accepted Solution

Hero session camera won't power up, just shows solid blue light when plugged in

My GoPro Session suddenly would not power up after some use. Tried hard reset, a new SD card, all of the above. I plugged it into it's charger and see a SOLID blue light on the back of the camera, and a faint but also solid blue light on the front LED. Small LED screen on top does not turn on at all. My computer will also not recognize the camera as being plugged in, most likely as it won't actually fully power on. 

 

Has anyone experienced this? Ive seen threads where the blue light is flashing, but none about a solid blue light, and none describing these same symptoms. 

 

Any help is appreciated, thank you! 


Accepted Solutions
GoPro
Posts: 3,505

Re: Hero session camera won't power up, just shows solid blue light when plugged in

 

Hi @achsa,

 

Have you tried using other cable?

Try to charge it using other cable. 

 

Try to press and hold the mode button. 

 

If it won't work contact our customer support team. 

 

They can help you. 

https://gopro.com/help/ContactUs

 

Regards,

-Jay 

 

 

View solution in original post


All Replies
GoPro
Posts: 3,505

Re: Hero session camera won't power up, just shows solid blue light when plugged in

Hi @graydive3675,

 

 

Please try to repeat what you did and also try to press and hold the mode button. 

 

If issue persist please contact our customer support team via phone or chat. 

 

 

Regards,

-Jay 

Sightseer
Posts: 2

Re: Hero session camera won't power up, just shows solid blue light when plugged in

same issue here! Still waiting for THE answer

Sightseer
Posts: 2

Re: Hero session camera won't power up, just shows solid blue light when plugged in

same issue here! Still waiting for THE answer.

GoPro
Posts: 3,505

Re: Hero session camera won't power up, just shows solid blue light when plugged in

 

Hi @achsa,

 

Have you tried using other cable?

Try to charge it using other cable. 

 

Try to press and hold the mode button. 

 

If it won't work contact our customer support team. 

 

They can help you. 

https://gopro.com/help/ContactUs

 

Regards,

-Jay