Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Tourist
Posts: 3

Hero 9 Charging Issue

[ New ]

Wondering if anyone has had any issues with their Hero 9 charging? Mine charges to around 80% and then the red light starts to blink slowly. It doesn't seem that it will charge past this point and tonight it's turned itself on twice when reaching 80%! I've tried different chargers, different batteries. I've updated the firmware again, reset to factory settings, turned off connections etc. Thanks!

Sightseer
Posts: 1

Re: Hero 9 Charging Issue

[ New ]
I'm having a problem with one of the batteries too. Stopped at 87%, and the red light started doing a strange long then short blink. First time charging it. Tried different cables, nothing. Waiting to see what happens with the other battery, first recharge after it went to 100%.
Tourist
Posts: 3

Re: Hero 9 Charging Issue

[ New ]
Exact same thing for me. I tried the other battery and it did the same. On the rare occasion it will charge to 100%
GoPro
Posts: 27,018

Re: Hero 9 Charging Issue

[ New ]

Hello @cwilson3105 @deepoceaniv 

 

What is the charging output of the adapter used?

I have experienced the same with my camera but it went fine after a couple of charging cycles 

 

Thanks!

Ej

 

 

Tourist
Posts: 3

Re: Hero 9 Charging Issue

[ New ]
Hi Ej,

Thanks for the reply.

I’ve tried four types now:

1) 5V 3A / 9V 2A / 12V 1.5A
2) 5V 2.1A
3) 2.4A (Couldn’t find voltage but I suspect 5V)
4) 2.4A (Same as above)

Thanks,
Chris
Highlighted
GoPro
Posts: 27,018

Re: Hero 9 Charging Issue

[ New ]

Thanks! @cwilson3105

 

Let our Support Team check on this further.

Please submit a request for a callback or initiate a chat session through https://gopro.com/help/ContactUs

Should you encounter any issue scheduling a callback or a live chat, please ensure that you are not blocking cookies and have your pop-up blocker disabled.
You may also try a different browser or go on incognito mode.
 

Regards,

Ej