Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see if it is on our Update page.
Cameras
Reply
Hiker
Posts: 12

Hero 9 Black fails to upload large files.

[ New ]

Hey Party People,

    When I take extended footage on my Hero 9 Black, I will dock and upload, and be notified that uploads are complete. However, the large files fail to become visible in the cloud. Example large file size: 22+ GB.

 

The first time this occurred, I figured it was a premature marking of file upload completion. I shot a photo on the camera, re-docked, re-uploaded, and got the expected result.

 

The second time this occurred, the first workaround failed (but I did not try it multiple times). I resorted to using an SD card reader, copying to a laptop, and uploading through the web portal. 

 

In case you're curious, most of my clips aren't 22+ GB. This is usually an issue when I forget my remote and go for long continuous shots that I plan on editing later.

 

Cheers~

GoPro
Posts: 32,193

Re: Hero 9 Black fails to upload large files.

[ New ]

 

Hi @jamesm5132

 

Thank you for the details shared.

This usually depends on the stability of the network used. 

I was able to upload a 24GB file to the cloud. It is a 50-minute long 360 video.

Make sure that your device is connected to a strong and stable Wi-Fi network.

 

Regards,

Ej

Hiker
Posts: 12

Re: Hero 9 Black fails to upload large files.

[ New ]

Hi Ej,

    An upload can get interrupted on an unstable connection, but this does not address the fact that the camera thinks it is finished uploading files. When I would plug the camera in a second time, it would not detect any new media to upload, and it would not initiate an upload sequence -- i.e., it stopped retrying the upload. This is what prompted me to shoot a photo the first time I encountered it - to re-trigger upload.

 

Cheers

GoPro
Posts: 32,193

Re: Hero 9 Black fails to upload large files.

[ New ]

Hi @jamesm5132

 

Try resetting the camera then set up auto-upload again.

Do some test recording then see if the upload will initiate.

 

If you continue to observe the same, it will be best to reach out to Support to have this checked further.

You may submit a request for a callback or initiate a chat session through https://gopro.com/help/ContactUs
Please let them know of the troubleshooting steps taken.
 

Thanks!

Ej