Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Tourist
Posts: 4
Accepted Solution

Hero 8 won’t power on

Brand new hero 8 black. When I push power/mode button it beeps 3 times and takes a still picture. Remove battery and reinsert and automatically beeps 3 times and takes a still picture. 2 new batteries fully charged and I cannot get the camera to do anything other than this

Accepted Solutions
Highlighted
GoPro
Posts: 20,052

Re: Hero 8 won’t power on

Hi @kennetht30162

 

Please run a manual software update. https://gopro.com/en/us/update
Once the update is completed, reset the camera to its factory settings. https://community.gopro.com/t5/en/Reset-Camera-Settings/ta-p/388279
Do a test photo/recording and see if it made a difference. 
Let us know how it goes.

If it's still the same, please reach out to our Support Team.
They are available by phone or chat through https://gopro.com/help/ContactUs
 

Thanks!

Ej

 


 

View solution in original post


All Replies
Highlighted
Adventurer
Posts: 13,476

Re: Hero 8 won’t power on

No one wants to hear  what sd card you are using but what happens when no sd card is in?

Highlighted
Adventurer
Posts: 13,476

Re: Hero 8 won’t power on

Without a sd card,  turn on the camera by Mod only. can you  work  the features and functions?

 

 

Highlighted
Tourist
Posts: 4

Re: Hero 8 won’t power on

does the exact same thing whether there is and SD card or not

Highlighted
Tourist
Posts: 4

Re: Hero 8 won’t power on

[ Edited ]

this is what happens 3 seconds later without pressing any buttons.  it automatically comes on and takes a picture

go pro 2.jpg
Highlighted
Tourist
Posts: 4

Re: Hero 8 won’t power on

this is after turning go pro off 

go pro 1.jpg
Highlighted
Adventurer
Posts: 13,476

Re: Hero 8 won’t power on

time to chat to a rep I guess,right?

 

Highlighted
GoPro
Posts: 20,052

Re: Hero 8 won’t power on

Hi @kennetht30162

 

Please run a manual software update. https://gopro.com/en/us/update
Once the update is completed, reset the camera to its factory settings. https://community.gopro.com/t5/en/Reset-Camera-Settings/ta-p/388279
Do a test photo/recording and see if it made a difference. 
Let us know how it goes.

If it's still the same, please reach out to our Support Team.
They are available by phone or chat through https://gopro.com/help/ContactUs
 

Thanks!

Ej