Ask a Question
GoPro Support Hub Ask a question. Share an answer. Find a solution. Stay stoked.
Announcements
Is your GoPro gear up to date? Check to see If it is on our Update page.
Cameras
Reply
Highlighted
Tourist
Posts: 3

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

I have the same issue that I can't connect to any WiFi when trying live stream over RTMP. My phone is OnePlus 7 Pro, if that matters with Android 10 + Oxygen OS 10.0.7GM21BA.

 

I tested following things on my GoPro and phone setup:

  • I rolled back firmware, but that didn't help (currently runnign the latest 2.01)
  • Then I uninstalled the latest GoPro app (at the time of writing 7.1) and started to test with older versions. (I know it is bit sketchy), but I found now that at least for me when I have version 6.18 installed the RTMP live streaming started to work. I tried few times to restart both phone and my Hero 8 Blacnk and now I seem to be able succesfully do the live stream both using home WiFi and phone as hotspot.

Maybe this helps others and I am not going to post here any links where I downloaded the older APK. You'll find them if you just Google, but maybe this could give some insights for the GoPro dev team.

Highlighted
Tourist
Posts: 4

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

Same exact thing happened to me. Factory reset my phone, loaded older firmware to the camera etc. Only thing that worked was using an old version of the app. As soon as you try and go live it kills all wireless connection look up. However of you look at your phone you can clearly see available Networks. GoPro just released firmware to resolve connection issues. I would suspect they are aware of this but haven't found a fox yet.
Highlighted
GoPro
Posts: 16,023

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

Hello, Everyone. Sorry to hear that you are having issues with the live stream feature of the app. Based on the descriptions, we see that you are unable to live stream via RTMP using a Wi-Fi network. This is so with the latest (7.1) version of the GoPro App. 

 

We'd like to gather additional details so we can isolate the issue and provide the environment for our App team to replicate it. 

 

The information below will be greatly helpful. 

  1. The model of the phone that you are using and the OS it is on
  2. The current version of the GoPro app that you are using, as well as the version with which stream function works. 
  3. The title indicates HERO8 Black, but is the issue observed with other camera models as well? 
  4. Screenshot, if any, of the error screen on the app. 

We hope to hear back from you. Many thanks! 

Highlighted
Tourist
Posts: 4

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

Gopro: Hero 8 Black version 2.01
Phone: Galaxy S10 Android version 10. 0
App: version 7.1
Screenshot_20201009-011233_GoPro.jpg
Highlighted
GoPro
Posts: 16,023

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

Thank you for the information, @heroiccres14127. We tried replicating the issue on an Android 10 (Samsung) device but we were able to live stream via Wi-Fi to both the app and RTMP. This is using a HERO8 Black on firmware v2.01 as well. Will you be able to try again using a different phone? Thanks!

Highlighted
Tourist
Posts: 4

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

I was able to stream originally with my current set up and then one day I couldn't. I tried my gopro with an iPhone 11 and was able to stream with no problems @mariustanya
Highlighted
GoPro
Posts: 16,023

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

Thank you for the confirmation, @heroiccres14127. We will check with the App team if there is any known issue with your particular phone model. We will keep you posted here. 

Highlighted
Tourist
Posts: 10

Re: Hero 8 won't connect to Internet WiFi preventing me from live streaming

Any update on this @mariustanya? I'm having the same problem with the Android app and Hero 8. Based on what I'm seeing and what others are saying, I'm thinking this is a bug in the Android app. Is there a way to file an official bug report for the Android app besides posting this to the Android app support forum? Thanks!